repeating content for large pages

VERIFIED WORKSFORME

Status

P3
major
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: petter.sundlof, Assigned: harishd)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I've discussed this with "shaver" a bit, and it seems to be Mac OS specific, and
more specifically, specific to local files.

When rendering large pages, like 20+ KB, it at some point repeats the content,
breaking the document somewhere and starting from the top. It doesn't loop, it
just renders it an entire time and it ends.

Let me illustrate

The page looks like this in Netscape 4.x:

A)Start
B
C
D
E
F
G
H)End

And in Mozilla (M11, 1999-10-14-11, and older ones):

A)Start
B
C
D
A)Starts from top, breaking in the middle.
B
C
D
E
F
G
H)End

If I for example have Javascript at the top, it works only on the second,
repeating part.

I've checked if it has something to do with my HTML, but it doesn't. I replaced
all HTML that could matter with plain text, but it still occurred.

Updated

19 years ago
Assignee: chofmann → rickg

Comment 1

19 years ago
parsing problem?
(Reporter)

Comment 2

19 years ago
I do not understand what you mean by "parsing problem".

Updated

19 years ago
Assignee: rickg → harishd

Comment 3

19 years ago
Can you try tracking this down please?
(Assignee)

Comment 4

19 years ago
odd@findus.dhs.org, could you please give me a reduced case to reproduce the
problem.  Because I'm not seeing the repeat problem.
(Reporter)

Comment 5

19 years ago
Sorry if I didn't say this - but it's most likely a MAC-specific bug. I talked to

shaver@netscape.com about this.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
Verified with Mac 8.6 and Mac 9.0 both load fine.

FYI: Tested with Oct. 19th build.

Marking bug WORKSFORME.
(Reporter)

Comment 7

19 years ago
Well, guess I'll just skip it. Might check back when I've tried a build => 19

oct.

Comment 8

19 years ago
Marking Verified as WorksForMe per above comments.  Please use latest nightly 
build from: http://www.mozilla.org/binaries.html and reopen bug if is happens 
again.  Thanks!
Status: RESOLVED → VERIFIED

Updated

16 years ago
Summary: repeating content for large pages
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.