Closed Bug 1658220 Opened 6 months ago Closed 5 months ago

Bug 1657363 breaks printer selection on windows because "last used printer" mechanism is broken.

Categories

(Core :: Printing: Setup, defect, P2)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I gave bug 1657363 a spin on windows and it regresses some behavior. Turns out that the default printer mechanism is busted with the new UI, but it kinda happened to work due to two things:

  • When there's no previous printer we used to fall back to system default before bug 1657363.
  • Windows changes the system default printer each time you print, so this worked just as you'd expect.

Yay.

Flags: needinfo?(emilio)

This effectively restores the behavior on windows, though it still
doesn't fix the "save last used printer" functionality. This is the only
caller affected because on the others we fall back to the system default
if there's no printer name specified...

The map() is not the prettier, let me know if you have something cleaner
in mind.

Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/3d44841a5c38
Workaround old gcc which bogusly warns about hiding overloaded functions with different arguments by renaming a function.
Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7cd27996ce2
When building the printer list, select the system default if we don't find the last used printer. r=jwatt

Let's call this fixed, as it fixed the regression. Bob filed bug 1659122 independently to track the underlying "saving the printer is broken", so let's fix that there.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(emilio)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.