Closed Bug 1658221 Opened 6 months ago Closed 6 months ago

Build error: Cannot find rc

Categories

(Firefox Build System :: General, defect)

Unspecified
Windows 10
defect

Tracking

(firefox-esr68 unaffected, firefox-esr78 unaffected, firefox79 unaffected, firefox80 unaffected, firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: gerald, Assigned: glandium)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

On Windows 10:

$ ./mach build
...
0:21.18 checking for the assembler... C:/PROGRA2/MICROS1/2019/PROFES1/VC/Tools/MSVC/14261.288/bin/HostX64/x64/ml64.exe
0:21.19 checking for rc... not found
0:21.19 DEBUG: rc: Trying llvm-rc
0:21.19 ERROR: Cannot find rc
0:21.27 *** Fix above errors and then restart with
0:21.27 "./mach build"
0:21.49 mozmake.EXE: *** [client.mk:115: configure] Error 1

It happened after pulling https://hg.mozilla.org/mozilla-central/log/d1de0bdfee4f , which includes bug 1537703.
I tried clobber and bootstrap.

There is a ~/.mozbuild/clang/bin/llvm-rc.exe.

Mike, could you please have a look? Please ping me if you need more info.

Flags: needinfo?(mh+mozilla)
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mh+mozilla)

I've just tried your attached patch, and it solved my problem. Thank you for the quick fix!

Duplicate of this bug: 1658249
Duplicate of this bug: 1658338
Blocks: mach-busted
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2f16161f029
Look for llvm-rc in the toolchain search path. r=dmajor
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.