[META] Tracking Bug for "Get Msgs" button does not work

RESOLVED INVALID

Status

RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: mgabriel, Unassigned)

Tracking

({meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
loads of bugs related to this out there.
too many to figure out dupes without some clearing
(Reporter)

Updated

16 years ago
Depends on: 129629
(Reporter)

Comment 1

16 years ago
humm, seeing at how many people im sending mails out here im getting scared.
can anybody confirm my doing ?
if you disapprove, just invalid this.

Comment 2

16 years ago
Adding some bugs I ran into. Probably many dupes.

pi
(Reporter)

Updated

16 years ago
Depends on: 103363, 140741, 144593, 150316, 150491

Comment 3

16 years ago
> humm, seeing at how many people im sending mails out here im getting scared.
> can anybody confirm my doing ?

It's OK to file a useful tracking bug, but usually it's best to assign it to
either yourself or nobody@mozilla.org, as default assignees and QA contacts tend
to have a lot of bugs to look after already.

And tracking bugs should always have the 'meta' keyword.
Keywords: meta
(Reporter)

Comment 4

16 years ago
well then ...
Assignee: sspitzer → nobody

Updated

16 years ago
Depends on: 127461

Updated

16 years ago
QA Contact: olgam → stephend

Updated

16 years ago
No longer depends on: 140812

Updated

16 years ago
Depends on: 172939

Updated

16 years ago
Depends on: 132538

Updated

16 years ago
No longer depends on: 132538

Updated

16 years ago
Depends on: 132538

Comment 5

16 years ago
I found two dupes of 111102:
http://bugzilla.mozilla.org/show_bug.cgi?id=140741#c7
http://bugzilla.mozilla.org/show_bug.cgi?id=172939#c3

There are lots of similarities amongst the other bugs, but they are mostly
concerned with the functionality not working, not being unable to access it due
to something disabled.

Only these three bugs are concerned with when the getmsg button is actually
disabled.

Thanks for the pointer, pi

Updated

16 years ago
Depends on: 166061

Comment 6

16 years ago
Could someone please add the word "button" to the summary? Then more people
(like me) would find this meta-bug

Updated

16 years ago
Summary: [META] Tracking Bug for "Get Msgs" does not work → [META] Tracking Bug for "Get Msgs" button does not work

Comment 7

16 years ago
I've seen a problem with the last week or so of nightly builds where Get Msgs
doesn't do anything.  I can click it, but it never checks the server or
anything.    Right clicking the account name and hitting Get Messages for
Account also never produces any network traffic.  The autocheck for new mail
every n minutes doesn't work either.  When I first open the mail client, it asks
for my password, and any new messages on the server appear then.  Checking for
new messages (by either of the previously mentioned methods) later without
closing the client and reopening it does nothing.

I'm not sure this is the best place to post this, or if I should open a new bug.
 The account is an imap account, which previously worked with mozilla.

Browser id: 20021200221
Platform: Linux (Mandrake 9.0)

Comment 8

16 years ago
In response to comment 7, I believe the problem was related to switching from
the latest nightly builds to 1.2 and back to the nightlies.  1.2 froze when
opening the mail/news screen so I downloaded the latest nightly.  These
nightlies had the problem of not retrieving mail as described above.  After
deleting my .mozilla directory and using the latest nightly again, mail works fine.

Updated

16 years ago
Depends on: 180543

Comment 9

16 years ago
I'm using Mozilla 1.2.1 [Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; 
rv:1.2.1) Gecko/20021130] with one pop3-account and imap account.




Clicking on "Get Msgs" or any similar command from the menu doesn't have any 
reaction at all for my pop3-account. Normally I'm prompted for typing in my 
password for this account and after that everything works fine, but that doesn't 
work any more.




Curiously everything works, if I click on my imap-mail folder (mozilla prompts 
for password and then downloads the new messages).




I've been reading a lot about this bug (and some of its "dupes") on bugzilla but 
I'm not able to solve my problem (i.e. deleting the .msf-files). Is there any 
workaround, how to get mozilla downloading my mail?




P.S. Previously I've been working with Mozilla 1.1 and had the same problems. So 
that's why I updated to Mozilla 1.2.1 but with the effect, that the bug still 
remains. With Mozilla 1.1 at least the problem vanished (for some time) by just 
rebooting my computer :-( Now this doesn't help anymore either ...




Please let me know what to do or how I can help, because I think this problem is 
serious and disables normal working with Mozilla.

Comment 10

16 years ago
I have been fighting this one also.  Here is what I have been able to figure out
about it:

1.  It does NOT happen if you use IMAP.
2.  It DOES happen if you are using POP or movemail from a POP server.  I tried
this on a FreeBSD system using fetchmail/sendmail.
3.  You usually get a "wait" cursor around Inbox items when this happens.
4.  It doesn't matter how many or how few messages are in your Inbox.  I tried
moving everything from my Inbox to a different folder: still happend.
5.  Platform/OS doesn't seem to matter - this happens on Windows, Linux, and
FreeBSD.
6.  It doesn't matter where your mail folders are: on a local disk, or a network
disk.
7.  There are no options or settings that appear to affect this, one way or the
other.  At least none that I have found.
8.  Intervals between "events" range from minutes to hours.  Sometimes as long
as a day or so.
9.  It doesn't matter what kind of connection you have to your mail server:
ethernet, dial-up, etc.
10.  Once this happens, you have to completely exit all of Mozilla.  Exiting
from just the mail client doesn't do it.
11.  Once mozilla mail starts back up, it spends some time "building summary
file for Inbox".
12.  Note that when this happens, the "Get Msgs" button DOES move when you click
it.  There are some bugs reported where the button doesn't move anymore, but you
can still get mail using ^T, or something.  This is not that problem.  The
button moves, but doesn't do anything.  Neither do any of the other methods of
checking for and retrieving new mail.

This has been going on since I first tried Mozilla - version 0.9-something. 
It's been in all versions since.

I hope this gets fixed soon, because it is EXTREMELY discouraging to have to
completely restart things so often.  It can also be embarrasing.

There are additional discussions about this in bugs 173924, 135318, and 132538.

Comment 11

15 years ago
It seems to me that we have two discussions happening here.   The first relates
to the get messages button not working. The second to Mozilla not querying the
POP  server when get messages is pressed.  The summary of this problem appears
to relate to the first but much of the content relates to the second.

Q: should the these not be two bugs??

First Problem - get messages button disabled

http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c5


Second Problem - POP3 not downloading mail

http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c7
http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c8
http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c9
http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c10

I have been fighting the second problem as well for many releases on a RedHat
9.0 system.

http://bugzilla.mozilla.org/show_bug.cgi?id=213581 where the mail download
progress bar ran endlessly appears to have masked this or been related to this.
  When this was fixed it became clear to me that the download wasn't working.

http://bugzilla.mozilla.org/show_bug.cgi?id=215547 may be related but there
isn't enough information.

http://bugzilla.mozilla.org/show_bug.cgi?id=204702 appears to be related.

http://bugzilla.mozilla.org/show_bug.cgi?id=127461 shows a version of the
problem with multiple POP3 accounts where all but one account stops retrieving
messages.  Also, if there is only one account it stops.  I have been examining
the nspr log files to try and find a pattern and am willing to investigate
further but some suggestions would be helpful (I could run a complete tcp trace
of the mail traffic but surely someone can think of something less drastic to
try first).

David



Comment 12

15 years ago
Update on the problem of no SEND USER quriese to the POP3 server.  I may have
found a clue as to what's happening.

About 11/17 I changed my mail configuration to automatically retrieve mail on
all accounts.  I also changed the wait period between each of my accounts
checking for mail automatically to (10, 30, and 60 minutes each). Under "server
settings" "automatically download mail" is checked on all but #2 (off by
mistake) yet mail is automatically retrieved on all.   Since then the problem
has been happening almost daily.

I'm currently piping the nsprlog files into a program which prepends a
timestamp.  Also a netstat is issued after any record with "SEND: USER". 
Currently, I have a couple of dozen logs from problem sessions. 

I'm looking for a pattern but I don't see one that's obvious.  It would help if
I knew what the 'states' listed in the log mean.  But I haven't seen a pattern
there. 

Only the first account on te server stops being polled.  Suddenly, I just stop
seeing records with SEND: USER <firstaccount>.

I've been through a handful of the logs and have noticed something.  It appears
that most of the time there are three POP3 connections open (one for each
account).  However, at the last instance of the first account being queried only
one POP3 connection is open.  After that at the next SEND USER there are two
POP3's open but account#1 is never seen on a SEND USER again.  

It may be nothing but I'm hoping it is and it will give someone an idea as to
what's happening.  I'm game to run some diagnostics or tests as long as this
continues and if someone can come up with some ideas as to what to try next.

Thanks, David

Comment 13

15 years ago
Another clue, any of the accounts that have automatic mail checking can become
the account that gets ignored by Mozilla.  I altered the automatic mail check
intervals on my  accounts.  The first account is no longer the one being ignored
most of the time.  It usually affects the account that gets checked most frequently.

Comment 14

15 years ago
I also noticed that all labelled mail becomes unlabelled after restarting
Mozilla.  Makes that feature (whick I like) unuseable :(

Comment 15

15 years ago
I don't know if this helps, but I notice that the file Inbox.msf seems to
be open right now while my Get Msgs button isn't working.  

(I tried renaming Inbox.msf (to temporarily "hide" it) using Windows 
Explorer, but it said the file was open.  I selected a different mail 
folder in Mozilla, but I still couldn't rename the file.)

I'm using:
- one POP mail server
- Mozilla 1.6
- Windows XP.
I have a bunch of browser windows open, had several mail windows open, 
have an applet with several applet windows open (Sun JRE/J2SDK 1.4.2_01). 
The Get Msgs button worked under these conditions for a while, but then
stopped working.

Some things I might have done between when it worked and when it didn't
are:
- uploaded files in the browser
- opened new browser windows via (NT)Emacs (editing an HTML file and
  pressing control-C control-V)
- viewed a PDF file with Acrobat 6 (suspicious because it hangs Mozilla with
  high CPU load while the PDF document loads)
- had several compose windows open at once.

(Netscape 4.7x windows sometimes become partially unresponsive if another
window has a window-specific modal dialog open.  My current Mozilla 
situation is not the same, but maybe there's something similar going on.)

Comment 16

15 years ago
Maybe, bug http://bugzilla.mozilla.org/show_bug.cgi?id=214314 can be placed here?

Comment 17

15 years ago
After a switch from Mozilla 1.1/RPM to 1.6/binary installer on Linux the exact
behavior as decribed in comment 7
(http://bugzilla.mozilla.org/show_bug.cgi?id=165832#c7) was introduced. Just
that the servers i use are POP3s

I reused my old profile and I'm positively sure nothing else except my client
has changed.

Is this a correct place where to put such a comment? Or shouldn't META bug be
polluted by more reports/confirmations?

Updated

15 years ago
Depends on: 248733
(Reporter)

Updated

14 years ago
Depends on: 173505
(Reporter)

Updated

14 years ago
Depends on: 257192

Updated

14 years ago
No longer depends on: 257192

Comment 18

14 years ago
Adding dependency on Bug 269725 - Status bar not showing the get msgs status
after opening a message.  

This just regressed since Seamonkey 20041025.  This bug makes it appear that Get
Msgs is not working because the Status bar messages go to a child window, and if
child window is closed, they go nowhere.  
Depends on: 269725
Product: Browser → Seamonkey

Updated

14 years ago
Depends on: 189469

Updated

13 years ago
Depends on: 302975

Updated

12 years ago

Comment 19

12 years ago
*** Bug 348771 has been marked as a duplicate of this bug. ***

Updated

12 years ago
No longer depends on: 318645
Assignee: nobody → mail
QA Contact: stephend
Assignee: mail → nobody
QA Contact: message-display

Comment 20

10 years ago
optimistically marking this to revisit in 3 weeks in hopes that there are no (or only one) issues left at that point to keep this open.
Whiteboard: closeme 2008-12-28 [reexamine]
I only see Bug 236512 open and UNCO, so it seems like this could be closed.

Comment 22

10 years ago
only one bug outstanding. resolving ...
=> invalid
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Whiteboard: closeme 2008-12-28 [reexamine] → closeme 2008-12-28

Updated

8 years ago
Whiteboard: closeme 2008-12-28
You need to log in before you can comment on or make changes to this bug.