Closed Bug 1658549 Opened 4 years ago Closed 2 years ago

Can't enter numbers in form due to spin buttons

Categories

(Web Compatibility :: Site Reports, defect, P3)

x86_64
Linux

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gcp, Unassigned)

Details

(Keywords: webcompat:site-wait)

STR:

  1. Enable non-native theming
  2. Go to https://www.mcmillanrunning.com/
  3. Try to use "Run Calculator"

You can't enter numbers because the spin buttons obscure the field. Checking in Chrome, the spin buttons aren't visible. I assume this is non-native theming fallout.

Blocks: linux-nnt
Component: Widget → Desktop
Product: Core → Web Compatibility

The page is using input::-webkit-outer-spin-button, input::-webkit-inner-spin-button { -webkit-appearance: none; }, which hides the spinners on WebKit / Blink.

input[type=number] { -moz-appearance: textfield } would achieve the same in Gecko.

No longer blocks: linux-nnt
Flags: needinfo?(miket)

I sent the site an email.

Severity: -- → S3
Flags: needinfo?(miket)
Priority: -- → P3

I was not able to reproduce the issue. I was able to introduce digits into the input field, without altering the settings of the browser.

https://prnt.sc/1vjLD4JUCHzb

Reporter, could you please provide extra steps to reproduce in order to set the non-native theming?

Tested with:

Browser / Version: Firefox Release 100.0.2 (64-bit)/ Firefox Nightly 103.0a1 (2022-05-30) (64-bit)

Flags: needinfo?(gpascutto)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gpascutto)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.