Closed Bug 1658605 Opened 2 years ago Closed 2 years ago

Enter search mode when token alias autofill is confirmed

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
82 Branch
Iteration:
82.1 - Aug 24 - Sep 6
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- disabled
firefox82 --- verified

People

(Reporter: mak, Assigned: mak)

References

(Regression)

Details

(Keywords: blocked-ux, regression)

Attachments

(1 file)

I was just trying to autofill an alias, I typed "@ama" pressed right, the space is not automatically inserted anymore, so I can't continue typing.

Is the update2 pref on? I intentionally removed the space since pressing space or enter with a typed/autofilled token alias should enter search mode now.

yes, it's on, the problem is that autofilling with RIGHT is a common thing in our autocomplete.

Yes, but the trailing space is an indicator that the user should just start typing. With search mode enabled, we'd like the user to hit space or enter to enter search mode first.

We can certainly revert to the old behaviour, but my understanding is that search mode is supposed to replace alias use altogether; aliases will just become a way to enter search mode. Maybe we could enter search mode when autofill is confirmed with right?

I'll mark this blocked-ux and discuss with Verdi.

Keywords: blocked-ux

(In reply to Harry Twyford [:harry] from comment #4)

We can certainly revert to the old behaviour, but my understanding is that search mode is supposed to replace alias use altogether; aliases will just become a way to enter search mode. Maybe we could enter search mode when autofill is confirmed with right?

I think I didn't explain well, I'm typing "@ama", I get suggested "@ama[zon]" I press RIGHT to confirm the "zon" completion, at this point search mode should be enabled, I should be able to continue typing, without having to further type another space.
Not entering search mode means that I get "@amazonmysearch" that is definitely not expected, I end up searching the whole string on Google.
If I press Enter instead of Right, it works as expected.

Oh, I see! Yes, I agree. Are you alright if we close this bug and handle this as part of bug 1657676? I could add a comment saying we should support the behaviour you describe.

Flags: needinfo?(mak)

bug 1657676 seems to be more about their visualization and a view bug, this is an input field bug.

Flags: needinfo?(mak)

Fair enough!

Points: --- → 3
Summary: token alias autofill is broken → Enter search mode when token alias autofill is confirmed

Hi Harry, are you expecting to get to this any time soon? Thanks!

Flags: needinfo?(htwyford)

This bug only affects users with the browser.urlbar.update2 pref enabled. That pref is currently Nightly-only. Its wider release was originally slated for 81, but it's since been pushed back to 82, so Beta 81 and Release 81 users will not experience this. I'm not sure how that should be reflected in release tracking.

Flags: needinfo?(htwyford)

I can probably look into this in the next days.

Assignee: nobody → mak
Severity: S2 → S3
Status: NEW → ASSIGNED
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/0d3406e53a85
Enter search mode when a token alias is autofilled. r=harry
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Iteration: --- → 82.1 - Aug 24 - Sep 6

The patch landed in nightly and beta is affected.
:mak, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(mak)

no need for this fix in beta.

Flags: needinfo?(mak)

I verified this issue using 82.0a1 (2020-09-14) on macOS 10.13 and Windows 10 x64.
Adrian could you help me with Ubuntu verification?

Flags: needinfo?(adrian.florinescu)

Verified as fixed using latest Nightly 82.0a1 2020-09-17 under Ubuntu 18.04 64-bit.

Status: RESOLVED → VERIFIED
Flags: needinfo?(adrian.florinescu)
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.