Closed Bug 1658723 Opened 2 years ago Closed 2 years ago

Settings not working

Categories

(Thunderbird :: Preferences, defect)

defect

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: pmbiesiada, Unassigned)

References

Details

Attachments

(7 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36

Steps to reproduce:

Updated from 68.10.0 to 78.1.1 x64 stable.

Actual results:

Settings/preferences are not working - there is no difference if I change any settings - it is not saved instantly and via restart of TB. File prefs.js is in its place but does not change. Making any change to settings does not have effect on settings tab and in prefs.js file.

Expected results:

Settings should change behavior, be saved and react to their change.

Assuming that you're not changing all settings at a time, pls provide a specific example for a pref change which fails.

(In reply to Thomas D. from comment #1)

Assuming that you're not changing all settings at a time, pls provide a specific example for a pref change which fails.

Ok, so:

  1. I enter settings=preferences
  2. I go down to disk cache
  3. I have both options unchecked and value 200
  4. I change second = check it, then make value 2
  5. I close settings
  6. I open once again
  7. I go down to disk cache and the values are from before the change

Restart of TB does not help here while messing around with settings.

Attached image Screenshot_10.png
Attached image Screenshot_11.png
Attached image Screenshot_12.png

Seems to work for me on trunk.

I cannot reproduce this on Mac 80.0b4 nor on Windows 78.1.1

Do you see anything in tools > developer > error console?

Flags: needinfo?(pmbiesiada)
Attached image Screenshot_15.png
Flags: needinfo?(pmbiesiada)

Because this was really annoying, I removed all non-account-related settings in prefs.js file and the problem with settings is gone.

However this shouldn't be this way for a simple user to mess around with prefs.js file when all he did is update TB to next version from time to time.

Based on this - this bug report shouldn't be closed as resolved, as the problem still exists with TB.

Do you still have a copy of the original prefs.js ?

Khushil, anything stand out in comment 8?

Flags: needinfo?(khushil324)
Blocks: tb78found

It can be related to language and associated string. Which language are you using?

Flags: needinfo?(khushil324) → needinfo?(pmbiesiada)

Polish.

Flags: needinfo?(pmbiesiada)

I downloaded Polish version and it seems that Thunderbird is completely broke.

I have added an account still it's not showing me anything in 3 pane window.

Once I restart, it's working fine. Still, I am not able to reproduce the preferences issue.

I don't think we've had other reports about this, so whatever it is, must be something with the profile/system.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.