Clicking on network/channel name has no effect

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: fredbezies, Assigned: rginda)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020830
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020830

After launching CZ, when I want to join a server (Moznet), it is like I click in
the void. Nothing :-/

Reproducible: Always

Steps to Reproduce:
1.Open chatzilla
2.click to reach a server


Actual Results:  
Nothing.

Expected Results:  
Connecting to a server !

1.1b clean install and clean profile.
(Reporter)

Comment 1

16 years ago
After some chat on #mozillazine, modifying some datas :-)

Manual attachment to a network (using "/attach" is working)

Summary: Cannot join any server in chatzilla. → Cannot attach to a network by clicking on its name.
(Reporter)

Comment 2

16 years ago
Modifying again summary.

Left click seems to be broken in Cz :-/
Summary: Cannot attach to a network by clicking on its name. → Cannot attach to a network by clicking on its name, neither to a channel !

Comment 3

16 years ago
Confirm using Trunk Build of September 1st.

But shouldn't we change the summary to "Clicking on network/channel name has no
effect" ?
If not please change it back.

The cause for this is, that if you click on it it will throw an javascript
exectpion of:

Error: parseIRCUrl is not defined
Source File: chrome://chatzilla/content/handlers.js
Line: 240


Also if you move the mouse over the channel name it displays

irc://moznet/%23mozillazine

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot attach to a network by clicking on its name, neither to a channel ! → Clicking on network/channel name has no effect"

Updated

16 years ago
Keywords: regression
OS: Windows XP → All
Summary: Clicking on network/channel name has no effect" → Clicking on network/channel name has no effect
(Reporter)

Comment 4

16 years ago
Thanks for confirming this bug :-)

And also, the %23 thing is not a bug !

I will nominate this bug for 1.2alpha

Comment 5

16 years ago
Yes, I know as %23 could URL encoded be #. But who knows what is causing Mozilla
to behave like this.

Comment 6

16 years ago
Try deleting compreg.dat.  It's in the components folder under where mozilla is
installed.
(Reporter)

Comment 7

16 years ago
There is NO compreg.dat in my mozilla folder.

I had installed a 1.1 final release, and deleted all folders / files but not :

- install.log
- Plugins and Uninstall folder - deleting npull.dll too

And I downloaded mozilla .zip file.

Here is the listing of my mozilla folder (long but interesting)

"02/09/2002  08:19    <REP>          .
02/09/2002  08:19    <REP>          ..
01/08/2002  15:59               215 bloaturls.txt
01/09/2002  15:35    <REP>          chrome
02/09/2002  08:16    <REP>          components
01/09/2002  15:31    <REP>          defaults
01/09/2002  04:32            16 384 dirver.exe
01/09/2002  05:55            96 816 gkgfx.dll
31/08/2002  12:37             3 699 install_status.log
01/09/2002  05:55            12 464 ISimpleDOMDocumentMarshal.dll
01/09/2002  05:55            20 384 ISimpleDOMNodeMarshal.dll
01/09/2002  05:55           326 592 js3250.dll
01/09/2002  05:55            62 624 jsj3250.dll
01/09/2002  05:55            14 112 MapiProxy.dll
01/09/2002  05:55           101 024 mfcembed.exe
25/03/2002  05:50             2 511 mfcembed.htm
01/09/2002  05:55            48 288 mfcEmbedComponents.dll
01/09/2002  05:55            18 048 mkdepend.exe
01/09/2002  05:55           223 200 mozctl.dll
01/09/2002  05:55             8 064 mozctlx.dll
01/09/2002  05:55           111 008 mozilla.exe
01/09/2002  05:55             6 112 mozMapi32.dll
01/09/2002  05:55           180 368 msgbsutl.dll
01/09/2002  05:55           139 264 nsldap32v50.dll
01/09/2002  05:55            24 576 nsldappr32v50.dll
01/09/2002  05:55           160 304 nspr4.dll
01/09/2002  05:55           307 200 nss3.dll
01/09/2002  05:55           180 224 nssckbi.dll
01/09/2002  05:55            29 792 plc4.dll
01/09/2002  05:55            25 424 plds4.dll
01/09/2002  15:35    <REP>          Plugins
01/09/2002  05:55             4 448 rebasedlls.exe
01/09/2002  05:55             3 920 regchrome.exe
01/09/2002  05:55             6 992 regExport.exe
01/09/2002  05:55             4 960 regxpcom.exe
01/09/2002  15:31    <REP>          res
01/09/2002  15:31    <REP>          searchplugins
01/09/2002  05:55           102 400 smime3.dll
01/09/2002  05:55           315 392 softokn3.dll
01/09/2002  05:55           110 592 ssl3.dll
01/09/2002  05:55             4 448 timebombgen.exe
31/08/2002  12:37    <REP>          uninstall
01/09/2002  05:55            29 024 winEmbed.exe
01/09/2002  05:55           516 624 xpcom.dll
01/09/2002  05:55            12 960 xpcshell.exe
01/09/2002  05:55            68 976 xpicleanup.exe
01/09/2002  05:55            56 496 xpidl.exe
01/09/2002  05:55             7 664 xpistub.dll
01/09/2002  05:55            23 584 xpt_dump.exe
01/09/2002  05:55            19 040 xpt_link.exe
01/09/2002  05:55            39 088 zlib.dll"

So, where is compreg.dat ?
(Reporter)

Comment 8

16 years ago
By the way (after reading to fast comment #6), it should not be related to
compreg.dat

Because I delete all folders (but not plugins and uninstall one) when installing
a new nightly !

Comment 9

16 years ago
we need to find out when this broke. bug 163225 broke JSConsole but we don't
think this is that.
fwiw mozilladir\components\compreg.dat
works in 2002-08-29-08
broken in 2002-08-30-04

Comment 11

16 years ago
I see this now.  The parseIRCUrl error I get when I right click on an irc link.
 Left clicks don't do anything, not even an error.
(Assignee)

Comment 12

16 years ago
someone decided to start passing newURI a baseURI, all the time.  I checked in a
fix that ignores baseURI, instead of bailing when it is present.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.