Closed Bug 1659034 Opened 2 years ago Closed 2 years ago

nsThread should only unregister itself from the profiler if it registered itself

Categories

(Core :: XPCOM, defect)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: gerald, Assigned: gerald)

References

Details

Attachments

(1 file)

nsThread should only call PROFILER_UNREGISTER_THREAD() if it called PROFILER_REGISTER_THREAD() with a non-empty name before.

This is probably not the cause of bug 1657174, which crashes with named threads; but it's the correct thing to do anyway.

Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd100ad06a48
Only call PROFILER_UNREGISTER_THREAD in nsThread::ThreadFunc if PROFILER_REGISTER_THREAD was called before - r=canaltinova
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.