Time remaining for net installer could be shown much more nicely

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: mpt, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: Mozilla 1.1, Windows 2000

To reproduce:
1.  Run the stub installer, up to the point where it is downloading components.
2.  Look at the time remaining.

What you see:
*   "0:01:13 at 77.49 KB/sec"

What's wrong:
*   Is that 1 minute 13 seconds? Or 1 hour 13 minutes? Or 1 day 13 hours? ...
*   It's almost certainly *not* going to be 1 minute 13 seconds, anyway. It'll
    probably be 1 minute 11 seconds, or 1 minute 14 seconds, or 1 minute 12
    seconds, or ... So, don't be misleadingly precise.
*   The leading zeroes are more cluttersome than useful.
*   The second decimal place in the KB/sec figure is much more cluttersome than
    useful.
*   What's a `sec', anyway?

What you should see:
*   "about 1 minute (77.4 K/second)"
*   That is, the time rounded usefully, giving an estimate which is meaningful
    without being misleadingly over-precise.

Simple method for rounding the time remaining:
*                           n < 7.5 seconds:           "less than 10 seconds"
*             7.5 seconds ¡Ü n < 55 seconds:            "about x0 seconds"
*              55 seconds ¡Ü n < 1 minute 30 seconds:   "about 1 minute"
*     1 minute 30 seconds ¡Ü n < 59 minutes 30 seconds: "about x minutes"
*   59 minutes 30 seconds ¡Ü n < 1 hour 30 minutes:     "about 1 hour"
*       1 hour 30 minutes ¡Ü n:                         "about x hours"

(NB: "¡Ü" is intended to be the less-than-or-equal-to symbol.)
Product: Browser → Seamonkey

Updated

13 years ago
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.