Closed Bug 1659121 Opened 1 year ago Closed 1 year ago

Orientation change resets the number of copies to default

Categories

(Toolkit :: Printing, defect, P2)

Firefox 81
defect

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- verified

People

(Reporter: Anca, Assigned: emalysz)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [Fixed by 1659302])

Affected versions

  • 81.0a1

Affected platforms

  • Ubuntu 18.04

Steps to reproduce

  1. Launch Firefox
  2. Open the new Print modal on any page
  3. Increase the numbers of copies
  4. Change the Orientation

Expected result

  • The numbers of copies stays the same

Actual result

  • The number of copies is reset to 1

Regression range

  • Not a regression

Additional notes

  • Windows and macOS are not affected
  • Reproduces both ways, regardless of the initial orientation state

Suggested severity

  • I think that S2 is suitable for this issue

There's an easy workaround available, but it might point to a bigger underlying issue…

Severity: -- → S3
Priority: -- → P2

I think this is just cause the copies aren't saved to prefs but we're repopulating the input from the settings when settings change. That code [1] can likely be deleted and the value can be initialized to 1 in print.html.

[1] https://searchfox.org/mozilla-central/rev/358cef5d1a87172f23b15e1a705d6f278db4cdad/toolkit/components/printing/content/print.js#404-406

Regression range

  • Not a regression
Has Regression Range: --- → yes
Keywords: regression
Has STR: --- → yes

(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #0)

  • Windows and macOS are not affected

This does reproduce for me on macOS: the Copies field resets to 1 as soon as I toggle the portrait/landscape orientation (or if I change other options: scale, headers & footers, backgrounds).

I'm wondering if this is really bug 1659302. If I type a number in and change the orientation it sticks, but using the spin button it gets reset.

Anca, do you mind checking if that's always the case on your end? These might be different manifestations of the same bug.

Flags: needinfo?(anca.soncutean)

(In reply to Mark Striemer [:mstriemer] from comment #5)

I'm wondering if this is really bug 1659302. If I type a number in and change the orientation it sticks, but using the spin button it gets reset.

Anca, do you mind checking if that's always the case on your end? These might be different manifestations of the same bug.

Yes, you are right, manual input doesn't reset for me at any option change attempt, only when using the arrow stepper (Windows 10, macOS 10.15 and Ubuntu 18.04), so the root cause is most likely described by bug 1659302.

Flags: needinfo?(anca.soncutean)
OS: Linux → All
Depends on: 1659184

(It sounds like this should be fixed by bug 1659302 so removing the [print2020_v81] whiteboard tag for easier tracking.)

Whiteboard: [print2020_v81]

Hi Anca, can you confirm whether this bug is fixed now that bug 1659302 is resolved?

Flags: needinfo?(anca.soncutean)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)

Hi Anca, can you confirm whether this bug is fixed now that bug 1659302 is resolved?

Yes, I can confirm the fix on Fx 81.0a1 (2020-08-20) across platforms (Windows 10, Ubuntu 18.04 and macOS 10.14).

Flags: needinfo?(anca.soncutean)
Assignee: nobody → emalysz
Status: NEW → RESOLVED
Closed: 1 year ago
Depends on: 1659302
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Status: RESOLVED → VERIFIED
Whiteboard: [Fixed by 1659302]
You need to log in before you can comment on or make changes to this bug.