Closed Bug 1659152 Opened 1 year ago Closed 11 months ago

Support zero onboarding flow

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
82 Branch
Iteration:
82.2 - Sep 7 - Sep 20
Tracking Status
firefox82 --- verified
firefox83 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Scope of this bug is to run experiment using X-Man with no onboarding as one of the branch

As of now only way to turn off onboarding is via pref flip using one or more of the below prefs
a) startup.homepage_welcome_url
b) browser.aboutwelocme.enabled
c) trailhead.firstrun.branches

The bug aims to fix turning off onboarding experience via flag passed using ExperimentAPI.In AboutNewTabService , before returning welcome URL we can check if no onboarding flag is set from Experiment API and redirect user to about:newtab.

This bug has dependency on remove trailhead about:welcome experience bug 1659150, which gets triggered when a new user is redirected to about:newtab

Assignee: nobody → pdahiya
Iteration: --- → 82.1 - Aug 24 - Sep 6
Priority: -- → P1
Iteration: 82.1 - Aug 24 - Sep 6 → 82.2 - Sep 7 - Sep 20
Summary: Support no onboarding flow without pref flip → Support zero onboarding flow
Duplicate of this bug: 1661732
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1feb16bc7ec7
Use ExperimentAPI to check enabled property of experiment branches r=k88hudson,andreio
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

I have verified that no onboarding is displayed, the about:welcome page automatically redirects to the about:newtab, and the about:newtab page is displayed when starting the browser with the --first-startup flag when the browser.aboutwelcome.enabled is set to false on the latest Nightly (83.0a1, 20200922154306) and Beta (82.0b2, 20200922183749) builds using Windows 10, macOS 10.15, and Linux MX 4.19.

Status: RESOLVED → VERIFIED
Blocks: 1666850
Depends on: 1668928
You need to log in before you can comment on or make changes to this bug.