Problems selecting context menu item w. right mouse button

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: mats, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
OVERVIEW DESCRIPTION:
Selecting a menu item in the context menu with the right mouse button
causes a crash if the menu has been popped up several times in a row with
the right mouse button only.

TO REPEAT:
1. start mozilla
2. click right mouse button on background to bring up the context menu
3. click right mouse button outside it to pop it up at another position
4. select a menu item in it with the RIGHT mouse button

You may have to repeat step 3+4 a few times but it always crash here for me:
MOZILLA caused an invalid page fault in module GKWIDGET.DLL

VERSION & OS:
mozilla nightly build 1999-10-15-12-M11 on Windows 98 SE.

Comment 1

19 years ago
This procedure also reliably causes a crash
with 1999-10-15-11-M11 on Windows NT

Updated

19 years ago
Assignee: trudelle → saari
Priority: P3 → P2
Target Milestone: M12

Comment 2

19 years ago
reproduced in today's win98 opt bits, reassigning to saari as p2 for m12

Comment 3

19 years ago
mass-moving all m12 bugs to m13

Updated

19 years ago
QA Contact: claudius → elig

Comment 4

19 years ago
[Contextual menu bug --- QA Assigning to self.]
QA Contact: elig → sairuh
assigning this contextual menu bug to me...
Component: XP Toolkit/Widgets → XPMenus

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M13 → M15

Comment 6

19 years ago
M15
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
cannot repro this on either win98 or winNT using today's comm. bits
(2000-011909). marking as wfm. lemme know if anyone else still sees this.

Comment 8

19 years ago
Testing with 2000-01-19-08-M13 nightly binary on NT, this bug no longer occurs,
but something strange does. If the Steps under "TO REPEAT" are followed exactly,
at the end of step 4 a *third* context menu will pop up in another location,
which will work normally.

This would hardly be worth reporting, except that if the click in step 4 is
changed to a LEFT click, that click does nothing. That problem has been filed
as Bug 24482, "Context menu does not work if repositioned before use".
This odd behaviour may provide a clue as to the cause of that bug.
(Reporter)

Updated

19 years ago
Severity: critical → normal
Status: RESOLVED → REOPENED
Priority: P2 → P3
Summary: CRASH: Selecting item in context menu w. right mouse button → Selecting item in context menu w. right mouse button
(Reporter)

Comment 9

19 years ago
IMHO, this bug is still alive - it just doesn't crash anymore. As
sidr@albedo.net noted there is a third menu appearing, the position of it and
the fact that it is possible to get two menu-items highlighted in this menu
indicates to me that there is still something broken here.
Anyway, a right click in a context menu probably should be taken as a left click
(as native menus do).

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 10

19 years ago
Clearing WORKSFORME resolution due to reopen.

Comment 11

19 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus

Comment 12

19 years ago
The right-click on context menu issue raised by mats@symsoft.se in latest
comment is the subject of bug 17159, "[4.xP] right click doesn't work within 
context menus" and bug 21549, "[4.xP] selecting item in context menu requires 
second click (left)", ASSIGNED to german@netscape.com, M16. 

The question has been raised in 21549, what popular apps allow 
ight-click-selection on a context menu? - the answer is clearly NN 4.x. 
Adding a notation to that bug to that effect.

So this bug can be about the weird behaviour, and 17159 and 21549 about using 
right-clicking on a context menu the same as a left-click.

Since this has been REOPENED, and pinkerton@netscape.com took all the rest
of the context menu bugs, here's one more ;-).
Assignee: saari → pinkerton
Status: REOPENED → NEW
Summary: Selecting item in context menu w. right mouse button → Problems selecting context menu item w. right mouse button
(Assignee)

Comment 13

19 years ago
bulk accepting xpmenu/popup bugs. sigh.
Status: NEW → ASSIGNED

Comment 14

19 years ago
You can also duplicate this weird menu behavior by double-clicking with the
right mouse button.  This opens a context menu at the pointer position, closes
it, then opens a second context menu in an improper position.

Comment 15

19 years ago
Sorry, a slight correction on that.  You first have to open a context menu
normally, with a single right-click, then double-click with the right mouse
button somewhere else in the window.

Comment 16

19 years ago
Odd.  I was playing around with nsContextMenu.js and found that the first time 
through, this.target.tagName.toUpperCase == "TD", while the second ("bad 
stuff happening") time through it's == "BROWSER".  This usually throws an 
exception because it falls through the big 'if' tree in setTarget() to the final 
'else'.  I got around this exception by throwing in:

} else if (this.target.tagName.toUpperCase() == "BROWSER") {
  // do nothing

before the final 'else', and now the second ("bad") menu that comes up is a 
frame-specific menu.

I don't know if this helps at all or not.
(Assignee)

Comment 17

19 years ago
moving all defects not directly related to P0 beta2 features off to M18.
Target Milestone: M15 → M18

Comment 18

19 years ago
Mass moving M18 bugs to M19
Target Milestone: M18 → M19

Comment 19

19 years ago
mass-moving all bugs to m21 that are not dogfood+ or nsbeta2+ or nsbeta2-
Target Milestone: M19 → M21
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm

Comment 21

19 years ago
Testing with the 2000-06-23-08-M17 nightly bianry on WinNT, this no longer 
appears to ba a problem.

Current behaviour:
A context menu is invoked by a right-click.
A right or left click elsewhere dismisses the context menu.
A right or left click on an item in the context menu activates it.
No odd behaviour depending on the sequence of clicks before trying to 
activate a context menu item.

If that's all according to spec, this chitinous critter can be calle w.f.m.
(Assignee)

Comment 22

19 years ago
ok, wfm too
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 23

19 years ago
verified wfm win32/linux/mac 20000626nn builds (mac using ctrl-click for 
context menu).
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.