Crash can occur after clicking on Print toolbar button

VERIFIED WORKSFORME

Status

Camino Graveyard
Printing
--
critical
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Chris Petersen, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({crash})

unspecified
Chimera0.6
PowerPC
Mac OS X
crash

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
Build: 2002-08-30-05 NB
Platform: OS X 10.2 (6c115)

Expected Results:  Print dialog should open
What I got: Clicking on print button resulted in crash


Steps to reproduce:
Below are steps I could reproduce more constantly under 10.2. Also, you need to
add the Print button to the main toolbar.

1) Go to http://homepage.mac.com/chrispetersen/PhotoAlbum18.html

2) Click on start slideshow which creates a JS window

3) Close the slideshow window

4) Click on print button on opened browser window

5) Application should crash
(Reporter)

Updated

15 years ago
Keywords: crash
(Reporter)

Comment 1

15 years ago
Created attachment 97401 [details]
Stack trace

Comment 2

15 years ago
FWIW, WorksForMe using Chimera/2002082705 on 10.1.5.
Severity: major → critical
(Reporter)

Comment 3

15 years ago
This appears to be a 10.2 only issue since I can't reproduce in 10.1.5 either.
(Assignee)

Comment 4

15 years ago
This part is interesting:

 #5   0x91d1eb78 in
PJCPrintDialogs::GetPanelkindFromPluginInterface(PlugInIntf*, __CFString const**)
 #6   0x91d058f0 in PJCPrintDialogs::LoadPMPDEs()

LoadPMPDEs. A PDE is Printer Dialog Extension and then, considering
GetPanelkindFromPluginInterface is next, looks like it found a PDE. We don't
package one for Chimera - strange.  
Status: NEW → ASSIGNED
Target Milestone: --- → Chimera0.6

Comment 5

15 years ago
This just happened to me last night, with nightly 2002100704. Twice. And it's
not just the toolbar button; I was using File > Print.

Stack trace is pretty much the same, so I'm not attaching it. I can if you guys
want.

Comment 6

15 years ago
While browsing and printing from 
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_DisplayProductInformation-Start;sid=3SAuuWh5lVQuL1XHlmgksid0ciQ2XajvYuE=?CatalogCategoryID=pL0KC0%2eNtnsAAADx9846Wy0D&ProductID=tlUKC0%2eNmHcAAADxjaI6Wy0H&Dept=hp
I had 2 different crashes. None of them are reproducible, but seems to happen a
bit randomly.


One has a stacktrace much like the attched except from the exact location, start 
of the trace for the crashed thread is below:

Thread 0 Crashed:
 #0   0x91a6a394 in CallTextWidth
 #1   0x91a8cedc in StringWidth
 #2   0x02ff0b24 in InitContext(PanelContext **)
 #3   0x02feda70 in Prologue
 #4   0x91d1eb6c in
PJCPrintDialogs::GetPanelkindFromPluginInterface(PlugInIntf*, __CFString const**)


The other crash occured while printing, also from the Sony site. See attached log.

Comment 7

15 years ago
Created attachment 104469 [details]
Crash log

Both happened with Build ID: 2002102804

Comment 8

15 years ago
This looks like another of our QuickDraw crashers. I wonder if the fix for bug
177369 fixes this.
(Reporter)

Comment 9

15 years ago
Using the 2002-10-30-04 build, this problem is still occuring using the original
steps provided. Tested under 10.2.1.
(Reporter)

Updated

15 years ago
Blocks: 147975
QA Contact: winnie → sairuh

Comment 10

15 years ago
I can't repro this. Was probably one of our QuickDraw crashers.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

15 years ago
Hmm... I can't reproduce this problem with the latest nightly (2002-12-31-04)
under 10.2.3. Marking WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.