Closed Bug 1659334 Opened 6 months ago Closed 6 months ago

ability to navigate to search homepage by performing keyword search for empty string lost

Categories

(Firefox :: Address Bar, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1659144
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 - wontfix

People

(Reporter: aryx, Unassigned)

References

(Regression)

Details

Since bug 1658326 turned the one-off update2 prefs in Nightly on, it's not possible anymore to navigate to search engine's homepage by performing a keyword search with an empty string. The keyword search works like a bookmark in that case and can take on e.g. to the start page of a news portal/catalog/advanced search mask.

Steps to reproduce:

  1. Open https://bugzilla.mozilla.org/home
  2. In the address bar, click on "..." on the right.
  3. Add the bugzilla search engine
  4. Press the Alt key.
  5. Open menu Edit/Tools > Options/Preferences.
  6. In the left sidebar, click on 'Search'.
  7. Go to the list of search engines.
  8. Add the keyword bugz for the bugzilla search engine.
  9. In the address bar, enter bugz.
  10. Press Enter.

Actual result:
bugz is converted to a blue styled element indicating it is a search engine.

Expected result:
Bugzilla opened.

  1. Press Enter once more.

Actual result:
Nothing happens.

Expected result:
Bugzilla opened

Unfortunately this is by design in update2. You'll have to use a bookmark keyword or some other method. I forwarded previous user feedback about this (bug 1659144) to UX and I'll do the same here.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1659144
You need to log in before you can comment on or make changes to this bug.