Closed Bug 1659366 Opened 5 months ago Closed 5 months ago

Intermittent toolkit/components/search/tests/xpcshell/test_config_engine_params.js | xpcshell return code: 0

Categories

(Thunderbird :: Upstream Synchronization, defect, P2)

defect

Tracking

(thunderbird_esr78 unaffected)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- unaffected

People

(Reporter: intermittent-bug-filer, Assigned: standard8)

Details

(Keywords: intermittent-failure, Whiteboard: [thunderbird-testfailure: X all])

Attachments

(1 file)

Filed by: mozilla [at] jorgk.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=313165295&repo=comm-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CiwW2h5hS5CGDhvZn1hhaQ/runs/0/artifacts/public/logs/live_backing.log


Heaps of search tests fail. Looks like it stated at this push but no one reported it :-(
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_config_engine_params.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_config_engine_params.js | test_get_extension - [test_get_extension : 12] Should have found an engine - null != null
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_identifiers.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_identifiers.js | test_from_telemetry_id - [test_from_telemetry_id : 32] Should have the correct identifier - "basic" == "telemetry"
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_initialization.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_initialization.js | test_initialization_failure - [test_initialization_failure : 1] Missing expected exception Should have failed to initialize
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/components/search/tests/xpcshell/test_json_cache.js | xpcshell return code: 0

Forgot to paste the push:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=bba92cc7febf01687f694dda5c4a3f9a9c87fb18
Bad M-C: 605c404fbd80c67e1127ac054b8bec6742bd748f
Good M-C: f46205a42faecda0e5a73bdcde0a8e1caa0126d9
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f46205a42faecda0e5a73bdcde0a8e1caa0126d9&tochange=605c404fbd80c67e1127ac054b8bec6742bd748f
Maybe bug 1657918 since bug 1658646 was backed out. But then that's about the some other search.

Whiteboard: [thunderbird-testfailure: X all]

Mark, you're quite active in TB these days (including doing some sheriffing). Can you tell where this came from?

Flags: needinfo?(standard8)

Hmm, looks like M-C removed https://hg.mozilla.org/mozilla-central/log/tip/browser/components/search/extensions/engines.json and we still have it, so we are months behind, and now it broke.

I'm getting out of practise :-(
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=605c404fbd80c67e1127ac054b8bec6742bd748f&tochange=7dcb2bda35c7d725759ffa5f53578898e0256662

Mark Banner — Bug 1658920 - Stop running legacy configuration for search tests. r=daleharvey

Only sheriffing because I landed things ;-)

In any case, when landing the removals I was sure I put in setting the modern config preference to true so that they would still pass for Thunderbird. Unfortunately that seems to have gone missing along the way so I guess I did something wrong somewhere.

I'll get a patch up.

Flags: needinfo?(standard8)

This was intended when we removed the legacy tests in bug 1658920, but was somehow missed/lost.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Priority: P5 → P2
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6893d7545a90
Force browser.search.modernConfig on in test for the time being so that Thunderbird tests past. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.