Closed Bug 1659530 Opened 6 months ago Closed 5 months ago

bypass 3rd party install panel for recommended addons

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

References

(Blocks 1 open bug, )

Details

Attachments

(5 files)

When installing an addon with an recommended state, skip showing the 3rd party site install panel. This requires moving that panel to show post-download.

Blocks: 1568635
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/761a09f4d153
skip 3rd party panel when installing recommended addons r=rpl

Hello,

I’ve explored around this new change using the builds provided in Comment 5 with several recommended add-ons: Privacy Badger (https://privacybadger.org/), NoScript (https://noscript.net/) and HTTPS Everywhere (https://www.eff.org/https-everywhere) on Windows 10 Pro 64 bit and Ubuntu 16.04 LTS.

These are the results:

  1. Privacy Badger: after clicking on the install link from https://privacybadger.org/, the the add-on is downloaded and only after download the 3rd party site install panel is displayed, as intended.
  2. HTTPS Everywhere: after clicking on the install link from https://www.eff.org/https-everywhere, the add-on is downloaded and only after download the 3rd party site install panel is displayed, as intended.
  3. NoScript: after clicking on the install link, the add-on is downloaded, however the 3rd party site install panel is skipped completely (it does not show at all during the install flow of the add-on)

For further details, please see the attached videos.

Attached image privacybadger.gif
Attached image noscript.gif
Attached image httpseverywhere.gif
Flags: needinfo?(mixedpuppy)
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d05f2016d467
skip 3rd party panel when installing recommended addons r=rpl
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Hello,

I’ve revisited this change as requested and checked both Nightly (83.0a1/20201008210150) and Beta (82.0b8/20201006142214) on Windows 10 Pro 64-bit and Ubuntu 16.04 LTS. For this I’ve used the previous tested add-ons (Privacy Badger, NoScript and HTTPS Everywhere) and a couple of new add-ons: Ghostery and DuckDuckGo Privacy Essentials. Please note that all the mentioned extensions are recommended on AMO.

These are the results for both browser versions:

Privacy Badger

  • installed from https://privacybadger.org/ . Add-on is downloaded, 3rd party site panel is displayed, permissions panel is displayed and then the add-on is added to the browser
  • recommended badge is NOT shown in about:addons

NoScript

  • installed from https://noscript.net/ . Add-on is downloaded, 3rd party site panel is NOT displayed at all, only the permissions panel is displayed and then the add-on is added to the browser
  • recommended badge is shown in about:addons

HTTPS Everywhere

  • installed from https://www.eff.org/https-everywhere . Add-on is downloaded, 3rd party site panel is displayed, permissions panel is displayed and then the add-on is added to the browser
  • recommended badge is NOT shown in about:addons

Ghostery

  • installed from https://www.ghostery.com/ . Add-on is downloaded, 3rd party site panel is NOT displayed at all, only the permissions panel is displayed and then the add-on is added to the browser
  • recommended badge is shown in about:addons

DuckDuckGo Privacy Essentials

  • installed from https://duckduckgo.com/ . Add-on is downloaded, 3rd party site panel is NOT displayed at all, only the permissions panel is displayed and then the add-on is added to the browser
  • recommended badge is shown in about:addons
Attached image addons manager.png

I manually downloaded httpseverywhere and privacy badger, those downloads do not include the recommended json file, so that is working correctly. The same version of the addon downloaded from AMO does include the recommended json file. The issue is that they are not using the same XPI file that is on AMO.

From that perspective, I'd consider this verified. I'll ask in slack about getting them on the right XPI.

Blocks: 1681331
You need to log in before you can comment on or make changes to this bug.