Closed Bug 1659630 Opened 5 months ago Closed 5 months ago

Enable BrowsingContext preservation in early beta

Categories

(Core :: DOM: Content Processes, task, P1)

task

Tracking

()

RESOLVED FIXED
81 Branch
Fission Milestone M6b
Tracking Status
firefox81 --- fixed

People

(Reporter: pbone, Assigned: pbone)

References

Details

Attachments

(1 file)

Relman have advised that we don't need an experiment for BC Preservation at this stage. We can enable BC preservation in early beta, if it looks good in early beta we may uplift a patch to let it ride to late beta and release.

Note that this is mostly-unused code on mobile, so by going to beta we're also going to beta on mobile and that's okay.

We're also waiting on QA, we expect to hear from them by Friday the 21st, merge day is the 24th.

Attachment #9170566 - Attachment description: Bug 1659630 - Enable BrowsingContext preservation in early beta r=ryanvm → Bug 1659630 - Enable BrowsingContext preservation in early beta r=cpeterson
Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d79778c6e1e
Enable BrowsingContext preservation in early beta r=cpeterson
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Not sure which bug to file the regression on, feel free to move it...

After this change browser_pdfjs_saveas.js starts hanging when using a release build. The test ends up hanging on BrowserTestUtils.waitForContentEvent on a browser that loads a file uri. The event makes it back to the parent process but fails this check.

Running with fission.preserve_browsing_contexts=true the test runs fine.

Flags: needinfo?(cpeterson)
Regressions: 1661173

Thanks, Brendan. I'll follow up in bug 1661173.

Flags: needinfo?(cpeterson)

Given that we've had BC preservation in nightly for a while, and that's where a lot of testing happens. It may almost be safer to let it ride since that might be the more well tested configuration.

You need to log in before you can comment on or make changes to this bug.