Closed Bug 1659670 Opened 5 months ago Closed 5 months ago

dmanip pinch gestures don't smooth zoom with keyboard modifiers since bug 1658647

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Summary: dmanip pinch gestures don't smooth zoom since bug 1658647 → dmanip pinch gestures don't smooth zoom with keyboard modifiers since bug 1658647

If you happen to have a full size keyboard with numlock defaulting to on this is very noticeable.

Severity: -- → S3
Priority: -- → P3
Attachment #9170621 - Attachment description: Bug 1659670. Don't add keyboard modifiers to direct manipulation pinch gestures. r?kats → Bug 1659670. Only consider non-lock keyboard modifiers when the APZC decides whether to ignore modifiers on pinch gestures. r?kats
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9ee9a2a6fec
Only consider non-lock keyboard modifiers when the APZC decides whether to ignore modifiers on pinch gestures. r=kats
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.