Closed Bug 1659736 Opened 3 months ago Closed 3 months ago

FX_MIGRATION_BOOKMARKS_ROOTS telemetry shows wrong value when importing bookmarks from Internet Explorer

Categories

(Firefox :: Migration, defect, P1)

Firefox 81
defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox81 --- verified
firefox82 --- verified

People

(Reporter: peter.magyari, Assigned: jaws)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Precondition
Make sure to only have Bookmarks/Favorites saved onto the Bookmarks/Favorites Toolbar in ie

Steps to reproduce

  1. Open Firefox
  2. Open the Bookmarks library by pressing "Ctrl+Shift+B" or from the Hamburger Menu
  3. Press the Import/Export Arrows -> Import Data from another browsers... button
  4. Select Internet Explorer
  5. Press Continue and make sure the Favorites item is checked then press Continue again
  6. Exit the Import Wizard by pressing Done
  7. Navigate to about:telemetry and search for the FX_MIGRATION_BOOKMARKS_ROOTS under Keyed Histograms

Actual Results
The telemetry value shows "3"

Expected Results
Since we've only imported bookmarks from the Favorites toolbar the value should should show "1"

Note
Regardless of where the Bookmarks were stored in ie the value always shows "3"

Can you take a look and triage this :jaws?

Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Severity: -- → N/A
Priority: -- → P1
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/538c51598420
Move tracking of bookmark roots during IE migration later so the source is clearer. r=Gijs
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f263318ebce4
Move tracking of bookmark roots during IE migration later so the source is clearer. r=Gijs
Flags: needinfo?(jaws)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a89b5580dd7
Move tracking of bookmark roots during IE migration later so the source is clearer. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

The patch landed in nightly and beta is affected.
:jaws, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(jaws)

Comment on attachment 9171769 [details]
Bug 1659736 - Move tracking of bookmark roots during IE migration later so the source is clearer.

Beta/Release Uplift Approval Request

  • User impact if declined: telemetry reporting will be incorrect for IE migrations
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Follow QA test plan for IE migrator telemetry reporting
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Fix only affects telemetry reporting
  • String changes made/needed: none
Flags: needinfo?(jaws)
Attachment #9171769 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9171769 [details]
Bug 1659736 - Move tracking of bookmark roots during IE migration later so the source is clearer.

Approved for 81.0b5.

Attachment #9171769 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Precondition:
Go to about:config and make sure "browser.migrate.showBookmarksToolbarAfterMigration" is set to true
Make sure to only have Bookmarks/Favorites saved onto the Bookmarks/Favorites Toolbar in ie

I followed the steps from the reported bug on Nightly 82.0a1 (2020-09-01)

  1. Open Firefox
  2. Open the Bookmarks library by pressing "Ctrl+Shift+B" or from the Hamburger Menu
  3. Press the Import/Export Arrows -> Import Data from another browsers... button
  4. Select Internet Explorer
  5. Press Continue and make sure the Favorites item is checked then press Continue again
  6. Exit the Import Wizard by pressing Done
  7. Navigate to about:telemetry and search for the FX_MIGRATION_BOOKMARKS_ROOTS under Keyed Histograms

Actual Results:
The telemetry value still shows "3" instead of "1".

@jaws@mozilla.com, am I missing something?

Flags: needinfo?(jaws)

I can't reproduce that. I see 1 in my local testing. Are you sure you don't have a bookmark in your menu?

Flags: needinfo?(jaws) → needinfo?(raluca.popovici)

Verified fixed on Nightly 82.0a1 (20200903151816) and Beta 81.0b6 (20200903205131)

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Flags: needinfo?(raluca.popovici)
You need to log in before you can comment on or make changes to this bug.