Closed Bug 1659740 Opened 1 year ago Closed 1 year ago

Print controls are not centered & are clipped, if you have a sidebar open

Categories

(Toolkit :: Printing, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1658138

People

(Reporter: dholbert, Unassigned)

Details

(Whiteboard: [print2020_v81])

Attachments

(2 files)

STR:

  1. View some page (e.g. http://www.example.org/ )
  2. Open the History sidebar (Ctrl+H)
  3. Ctrl+P to open the print UI

ACTUAL RESULTS:
The Print UI is pushed off towards the right side of the viewport, and clipped if your window is skinny enough (doesn't even have to be that skinny).

EXPECTED RESULTS:
Print UI should be centered to make use of the space that we have available (rather than running off the side of the viewport).

Attached screenshot is taken using the default-sized Firefox window in a fresh Firefox profile.

Attachment #9170687 - Attachment description: screenshot → screenshot with default-sized window (a few pixels clipped off the dialog on the right side)

(Just a guess: maybe this is improved by bug 1653317?)

Flags: needinfo?(mstriemer)
Summary: Print controls are not centered & clipped if you have a sidebar open → Print controls are not centered & are clipped, if you have a sidebar open

I think the TabDialogBox change might help the situation, but we might need to handle this explicitly in the resizing bug 1654962.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(mstriemer)
Resolution: --- → DUPLICATE
Duplicate of bug: 1658138
Whiteboard: [print2020] → [print2020_v81]
You need to log in before you can comment on or make changes to this bug.