Preferences only limit minimum font size, not maximum

RESOLVED WONTFIX

Status

()

Core
Layout: Text
P5
enhancement
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: Egon Face, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
There are very few sites which deliver in font size which is too large; in fact
using a modest resolution such as 1280 * 1025 I find it necessary to increase
the minimum to around 15, but when I view a site like
http://www.theregister.co.uk/ I have to manually reduce the zoom level to get an
acceptable font size. I have mentioned this to the site in question but they
have not responded to date and it occurs to me it would be nice to control this
as well as everything else that Mozilla enables its users to do so well.
Well... A maximum font size would not mean that the _base_ font size is
truncated at that but that _all_ font sizes (including headlines and the like)
are truncated at that size... Is that what you really want?
(Reporter)

Comment 2

16 years ago
I can't see why <h1> etc. cannot be handled as exceptions, but even if they
cannot I see no harm in limiting all fonts to a maximum of say 16. With all user
preferences its a trade off between the original design and the individual
preferences of the end browser.
Just making sure you know what you're asking for.  ;)

<h1> and so forth can't be exceptions because there's no real way to detect them.

confirming rfe.
Assignee: ben → attinasi
Status: UNCONFIRMED → NEW
Component: Preferences → Layout
Ever confirmed: true
OS: Windows XP → All
QA Contact: sairuh → petersen
Hardware: PC → All

Updated

16 years ago
QA Contact: petersen → amar

Updated

16 years ago
Priority: -- → P3

Updated

16 years ago
Target Milestone: --- → Future
.
Assignee: attinasi → font
Component: Layout → Layout: Fonts and Text
Priority: P3 → --
QA Contact: amar → ian
Target Milestone: Future → ---

Updated

15 years ago
Priority: -- → P5
Target Milestone: --- → Future

Comment 5

15 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030728 Mozilla
Firebird/0.6.1


http://homepages.inf.ed.ac.uk/s0231576/inspiron8200/install.htm

I've seen other pages similar to this, but nowhere near as big. CNN sometimes
has this title on their page, that also gets pretty large, letters an inch tall
or so.

Netscape 4 shows this page w/out a massive heading, but I'm guessing it doesn't
know what <big> is or <big><big><big><big><big><big><big><big><big><big> doesn't
mean the same thing to ns4 as mozilla. :)

user_pref("font.maximum-size.x-western", 24); would be nice to see one day. ;)

Comment 6

15 years ago
Created attachment 129686 [details]
huge font test

Comment 7

15 years ago
Created attachment 143823 [details] [diff] [review]
patch v1

against mozilla-1.7a

there's no config or documentation changes in this patch, only:
  mozilla/content/base/src/nsRuleNode.cpp
  mozilla/content/shared/public/nsRuleNode.h
  mozilla/layout/base/public/nsIPresContext.h
  mozilla/layout/base/src/nsPresContext.cpp
  mozilla/layout/base/src/nsPresContext.h
I don't see why we want this.  It's of relatively little value to users, as far
as I can tell.  (I probably should have marked it wontfix years ago.)
(Note that if the only reason you want this is because we marked bug 206235
wontfix, then I'd rather have bug 206235 fixed, although I don't think that's
worth it either -- and it's also nonstandard.)

Comment 10

15 years ago
just seemed like an obvious pref to complement font.minimum-size.[yadda]
There are lots of things we could implement, but then we'd be even bigger than
we already are.  If there's not a good reason for it, then we shouldn't do it.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 12

14 years ago
Created attachment 147168 [details]
huge font test v2 (non-<big>)

I fail to see how this is any different than a pref for the minimum font size.
The diff is 12k, perhaps a total of 2k added...

Reconsideration requested.
The pref for minimum font size is extremely useful for accessibility.

Comment 14

13 years ago
*** Bug 304283 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
Maximum font size really needs to be able to be limited.

Comment 16

2 years ago
I was looking for a setting of this sort in Firefox, and I found this report.

The minimum font size is excellent to ensure that things are readable in some websites, but I really need a counterpart maximum font size setting. Sometimes some parts of a page are too big to read (some parts, not the entire page, so zooming in/out is not a good solution).

Regarding comment 1 and comment 3 (is it for all content?), yes. In fact, sometimes it is exactly H1 and the like that need to be limited.

Regarding comment 8 (demand): it would be of value to me, at the very least. Comment 9 (nested <big>?): No, that's not what I'm looking for, I don't want to disable one way of making too large text, I want to get rid of all the "too large" text.
You need to log in before you can comment on or make changes to this bug.