Closed Bug 1660395 Opened 1 year ago Closed 11 months ago

Expose a Rust Future as C++ Promise

Categories

(Core :: XPCOM, task)

task

Tracking

()

RESOLVED DUPLICATE of bug 1679094

People

(Reporter: zbraniecki, Unassigned)

References

Details

In order to migrate Localization to Rust (bug 1613705), we need ability to return a result of an async function from Rust to C++ as a Promise.

The example of a hook is here: https://searchfox.org/mozilla-central/rev/d54210d490ef335b13fc1fcac817525120c8c46b/intl/l10n/Localization.cpp#261-262

The mLocalization is a JSM file that returns a Promise, and instead it will have to be a Rust function returning a Future.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1679094
You need to log in before you can comment on or make changes to this bug.