Closed Bug 1660411 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 25172 - Revert "FontAccess: Replace web_tests with WPT tests"

Categories

(Testing :: web-platform-tests, task, P4)

task

Tracking

(firefox82 fixed)

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 25172 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/25172
Details from upstream follow.

Maggie Cai <mxcai@chromium.org> wrote:

Revert "FontAccess: Replace web_tests with WPT tests"

This reverts commit cfb42f4aed1af85a1ae06a55c698e106213ac479.

Reason for revert: The upstream CL of this CL (https://crrev.com/c/2364009) is likely the cause of build breakage for Win10 Tests x64 build starting from: https://ci.chromium.org/p/chromium/builders/ci/Win10%20Tests%20x64/48700

Original change's description:

FontAccess: Replace web_tests with WPT tests

Replaces web_tests with WPT tests to ensure cross-browser compatibility
in the future.

Bug: 535764
Change-Id: Ice3b2bd0589a8aff83a0f50f7bcd2d2ff6938989
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2365332
Commit-Queue: Olivier Yiptong \<oyiptong@chromium.org>
Reviewed-by: Joshua Bell \<jsbell@chromium.org>
Cr-Commit-Position: refs/heads/master@{#800345}

TBR=jsbell@chromium.org,oyiptong@chromium.org

Change-Id: I6f85c0cb68f8c30ab29a618f3365d2473c9a8b99
No-Presubmit: true
No-Tree-Checks: true
No-Try: true
Bug: 535764
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2367585
Reviewed-by: Maggie Cai \<mxcai@chromium.org>
Commit-Queue: Maggie Cai \<mxcai@chromium.org>
Cr-Commit-Position: refs/heads/master@{#800478}

PR 25172 applied with additional changes from upstream: 75d50099b93041d023aa8e4b3ef30816d36eb485
Test result changes from PR not available.
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa69f3617a35
[wpt PR 25172] - Revert "FontAccess: Replace web_tests with WPT tests", a=testonly
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.