Closed Bug 1660713 Opened 10 months ago Closed 8 months ago

Active scope/search not indicated, has no affordance

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox81 --- affected

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: blocked-ux, nightly-community, ux-affordance)

Steps to reproduce:

  1. type %
  2. type a query

What happens:

The "tabs" icon/scope is not indicated; doesn't have an affordance.

Expected result:

I should have something in the UI that shows what search is selected in the scope bar.

An example of this can be seen in https://developer.apple.com/design/human-interface-guidelines/macos/buttons/scope-buttons/

Given that the scope can be activated via the scope bar (and the keyword/restriction characters seem to be a shortcut), I think this makes the connection via scope and suggestions more obvious. This is widely used (see apple HIG link above) and is an affordance beyond the keyword (which is frankly not all that discoverable).

Spun out from bug 1658964

Severity: -- → S4
Keywords: blocked-ux
Priority: -- → P5
Keywords: assertion

I think Search Mode in 83 is pretty much solving this.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME

Marco, I'm running 87 nightly right now and I'm not sure I understand what 83 did to resolve this request. Can you provide more details?

Flags: needinfo?(mak)

For examply by typing a space after %, that is the intended way for this to be used anyway. Long term we may make that a requirement.

Since these special characters are not much discoverable, I expect most users will use the buttons in the urlbar anyway, and when you use those buttons you'll get the search mode chiclet directly in the address bar input field.
Another possibility to speed up access may be to introduce a keyboard shortcut for Search Tabs (similar to CTRL+K to search the Web), and imo that would be a good idea.

Flags: needinfo?(mak)
You need to log in before you can comment on or make changes to this bug.