Closed Bug 1660798 Opened 11 months ago Closed 11 months ago

Convert parser code to use const ParserAtom* from JSAtom*

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: djvj, Assigned: djvj)

References

Details

(Keywords: perf-alert)

Attachments

(2 files, 3 obsolete files)

This is a sub-bug to capture the massive rename/conversion patch for the parser-atom migration.

Most of this has been posted and updated in the dependent (bug 1592105), but is being landed under this bug for organization purposes.

Assignee: nobody → kvijayan
Status: NEW → ASSIGNED
Attachment #9171704 - Attachment is obsolete: true
Attachment #9171702 - Attachment is obsolete: true
Severity: -- → N/A
Priority: -- → P2
Priority: P2 → P1
Pushed by kvijayan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12d099efac67
Part 1 - Adaptor glue to allow for parser to transition to internal atoms representation. r=mgaudet,tcampbell
https://hg.mozilla.org/integration/autoland/rev/846f88debca6
Part 2 - Convert uses of JSAtom* and PropertyName* to ParserAtomId and ParserNameId. r=tcampbell
Attachment #9171814 - Attachment is obsolete: true
Depends on: 1661086
Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2258849b0ee1
Part 1 - Adaptor glue to allow for parser to transition to internal atoms representation. r=mgaudet,tcampbell
https://hg.mozilla.org/integration/autoland/rev/e87bcd8a1f94
Part 2 - Convert uses of JSAtom* and PropertyName* to ParserAtomId and ParserNameId. r=tcampbell
Flags: needinfo?(kvijayan)
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Regressions: 1661454

== Change summary for alert #26805 (as of Fri, 28 Aug 2020 03:58:53 GMT) ==

Regressions:

4% Base Content Heap Unclassified windows10-64-shippable opt 1,496,656.00 -> 1,549,284.00

Improvements:

2% Base Content JS windows7-32-shippable opt 2,715,100.00 -> 2,666,001.33
1% Base Content JS macosx1014-64-shippable opt 3,492,022.00 -> 3,451,670.67
1% Base Content JS linux1804-64-shippable opt 3,486,957.33 -> 3,447,713.33
1% Base Content JS windows10-64-shippable-qr opt 3,491,781.33 -> 3,452,474.67
1% Base Content JS linux1804-64-shippable-qr opt 3,486,930.67 -> 3,447,713.33
1% Base Content JS windows10-64-shippable opt 3,564,864.67 -> 3,524,804.00

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=26805

The change in heap-unclassified is because we did not add accounting for the WellKnownParserAtoms table. With the small base-content JS improvement this comes out as memory neutral (add 50kB, save 50 kB).

Regressions: 1666237
You need to log in before you can comment on or make changes to this bug.