Closed Bug 1660861 Opened 1 year ago Closed 1 year ago

Make nsIPrintSettings.clone() not crash on macOS

Categories

(Core :: Printing: Setup, defect, P1)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- wontfix
firefox81 --- fixed
firefox82 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

(Keywords: crash, Whiteboard: [print2020_v81])

Attachments

(1 file)

As noted in bug 1660527 comment 6:

nsPrintSettingsX::nsPrintSettingsX(const nsPrintSettingsX& src) { *this = src; }

is broken since nsPrintSettingsX::operator=(const nsPrintSettingsX& rhs) can't be called on an uninitialized object since it calls [mPrintInfo release].

Comment on attachment 9171768 [details]
Bug 1660861. Make nsIPrintSettings.clone() not crash on macOS. r=emilio

Beta/Release Uplift Approval Request

  • User impact if declined: Print project blocker
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple crash fix for code that will only be exercised once new frontend code is added to use it.
  • String changes made/needed:
Attachment #9171768 - Flags: approval-mozilla-beta?
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/autoland/rev/4f7e328f6ad5
Make nsIPrintSettings.clone() not crash on macOS. r=emilio
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Comment on attachment 9171768 [details]
Bug 1660861. Make nsIPrintSettings.clone() not crash on macOS. r=emilio

Approved for 81.0b2.

Attachment #9171768 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.