Closed Bug 1661225 Opened 10 months ago Closed 7 months ago

[PI-713] The “move” PiP telemetry event is registered when the PiP window is opened or closed

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox80 --- wontfix
firefox85 --- verified

People

(Reporter: mheres, Assigned: baumga91)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached video move + close-open.mp4

[Affected Versions]:

  • Firefox Release 80 (Build ID 20200818235255)

[Affected Platforms]:

  • Linux Mint 19.2
  • Windows 10 (intermittently)

[Prerequisites]:

  • Have the latest Firefox Release 80 en-US build installed.
  • You are enrolled in any of the experiment’s branches.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and go to a video hosting site (e.g. YouTube).
  2. Open a video.
  3. Hover the video and click the PiP icon.
  4. Close the PiP window without moving it.
  5. Go to about:telemetry#events-tab and observe the telemetry events registered.

[Expected results]:

  • Only a “create” event is registered.

[Actual results]:

  • A “move” event is also registered besides the “create” one.

[Notes]:

  • The “move” event seems to be registered either when the PiP window is opened or closed (see attached video)
  • The issue is reproducible for all the tested websites.
  • On Windows 10, the event was only intermittently observed.
  • This issue is reproducible for all the branches of the experiment.
  • The issue was not observed on macOS 10.15;
  • Attached is a video of the issue.
Blocks: videopip
No longer blocks: 1651414
Assignee: nobody → baumga91
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a444d3c5172c
Wait for PiP window to focus before recording create telemetry. r=mconley
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

I have verified that the issue is no longer reproducible on Firefox Nightly 85.0a1 (Build ID: 20201118215158) using Windows 10 and Linux Mint 20. The issue is also not reproducible on macOS 10.15.
The move event is no longer recorded when PiP is opened or closed. It is recorded each time the PiP window is moved.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.