Closed Bug 1661255 Opened 6 months ago Closed 6 months ago

The Password Import Autocomplete options have overlapping highlight and click states

Categories

(Firefox :: Theme, defect)

Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1661244
Tracking Status
firefox80 --- unaffected
firefox81 --- fixed
firefox82 --- fixed

People

(Reporter: cmuresan, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image unknown.png

[Affected versions]:

  • Firefox Nightly 82.0a1, BuildID 20200824215021
  • Firefox Beta 81.0b1 BuildID 20200824150741

[Affected Platforms]:

  • Windows 10 x64
  • macOS 10.15.4

[Prerequisites]:

  • Have a clean new profile with no saved or imported logins.
  • Have a couple of logins saved in either Chrome or Edge (chromium)

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and navigate to a website that has a saved login in Chrome/Edge.
  2. Focus the username filed.
  3. Click and hold the first option and observe the behavior.

[Expected results]:

  • The option is in a clicked state (Blue background with white text).

[Actual results]:

  • The hover state and the clicked state overlap (grey background with white text).

[Regression Range]:

[Notes]:

  • The issue is reproducible on both Light and Dark themes.
  • Attached a screenshot of the issue.

@Mardak, could you please take a look at this?

Flags: needinfo?(edilee)

Reverting bug 1595743 does seem to fix the issue. I can reproduce the focus + hover problem for other password autocomplete items, e.g., generated password.

Looks like dupe of bug 1661244

Status: NEW → RESOLVED
Closed: 6 months ago
Component: Messaging System → Theme
Flags: needinfo?(edilee)
Resolution: --- → DUPLICATE
Duplicate of bug: 1661244
You need to log in before you can comment on or make changes to this bug.