Closed Bug 1661374 Opened 1 year ago Closed 1 year ago

If "save to pdf" is selected printer, populate the system dialog with settings of last accepted printer

Categories

(Toolkit :: Printing, enhancement, P2)

Firefox 81
enhancement

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox81 --- verified
firefox82 --- verified

People

(Reporter: emmamalysz, Assigned: emmamalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020_v81])

Attachments

(1 file)

In Bug 1659626, we opted to hide the system dialog link if the selected printer was "Save to pdf" for Windows and Linux.

Jonathan had suggested that we should instead keep the link, and if the user clicks on the link with a save-to-pdf printer, we would just populate the system dialog with the settings of the last "normal" printer.

Status: NEW → ASSIGNED
Attachment #9172300 - Attachment description: Bug 1661374, save last non-save-to-pdf printer name and allow user to open system dialog when saving to pdf is selected → Bug 1661374, save default printer name and allow user to open system dialog when saving to pdf is selected
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ace9714b4f2
save default printer name and allow user to open system dialog when saving to pdf is selected r=jwatt,mstriemer
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Comment on attachment 9172300 [details]
Bug 1661374, save default printer name and allow user to open system dialog when saving to pdf is selected

Beta/Release Uplift Approval Request

  • User impact if declined: User won't be able to open the system dialog when "save to pdf" is selected printer
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: 1. Open Firefox with print.tab_modal.enabled set to true
  1. Print page
  2. Switch to "save to pdf" printer
  3. Notice "open system dialog" does not disappear
  4. Click "open system dialog" link and notice the settings are populated with the default printer settings

On windows/Linux:

  1. Ensure no printers are available (Save to pdf is only option)
  2. Try printing
  3. Notice "print using system dialog" link is hidden
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No strings
  • String changes made/needed: n/a
Attachment #9172300 - Flags: approval-mozilla-beta?
Duplicate of this bug: 1662225

This has conflicts with at least bug 1661645. Not sure if you wanted to rebase around it or uplift that also?

Flags: needinfo?(emalysz)

(We want to uplift that too. I've pinged Mark.)

Flags: needinfo?(emalysz)
Duplicate of this bug: 1661653

Comment on attachment 9172300 [details]
Bug 1661374, save default printer name and allow user to open system dialog when saving to pdf is selected

Approved for 81.0b6.

Attachment #9172300 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

On OS X, I find this very confusing. I just ran into the situation where I applied some settings in the doorhanger (e.g. print backgrounds), then selected "print using system dialog" and my adjustments were gone. It's not obvious to the user why settings are set the way they are.

Is there a way we can respect (most) settings instead of using the ones of the last normal printer?

That makes sense to me. Since we're so late in the beta cycle already I've filed a new bug for v82, and we can figure out what to do and track the work over there.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

This is verified fixed using Firefox 82.0a1 (BuildId:20200907094115) and Firefox 81.0b7 (BuildId:20200906164749) on Windows 10 64bit. macOS 10.14 & Ubuntu 18.04 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.