Closed Bug 1661682 Opened 5 months ago Closed 24 days ago

Make test_bug450876.html pass on fission and xorigin mode

Categories

(Core :: DOM: UI Events & Focus Handling, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 582459
Fission Milestone M6c

People

(Reporter: edgar, Assigned: edgar)

References

Details

Test expects document.activeElement staying on the last focusable element (<a>) of the iframe after focus moves out of iframe by tab navigation. But with xorigin and fission enabled, the document.activeElement is reset to document after focus moves out of the iframe.

In other browsers, document.activeElement is reset to document after focus moves out of iframe. So it seems like the test expectation is wrong, and we have a bug on non-fission iframe. The OOP iframe somehow behavior correct, at least compare with other browsers.

Depends on: 582459

Hi Chris, can you assign a Fission Milestone here, please?

Flags: needinfo?(cpeterson)
Summary: Re-enable test_bug450876.html on fission and xorigin mode → Make test_bug450876.html pass on fission and xorigin mode

(In reply to Jens Stutte [:jstutte] (REO for FF 81) from comment #1)

Hi Chris, can you assign a Fission Milestone here, please?

Setting Fission Milestone M6c. Since this appears to be a test bug that affects non-fission iframe, this bug doesn't need to block our Fission Nightly experiment (Fission M6b).

M6c means fixing the bug soon (in September, ideally) is important, but it doesn't block our Fission Nightly experiment (October 6).

Fission Milestone: --- → M6c
Flags: needinfo?(cpeterson)

Tracking for Fission Beta milestone (M7).

Severity: S3 → N/A
Fission Milestone: M6c → M7
Assignee: nobody → echen

Per https://bugzilla.mozilla.org/show_bug.cgi?id=582459#c17, since the spec doesn't mention that we should reset document.activeElement on iframe when focus moves outside the iframe, so I think we should make OOP iframe behave the same as an in-process iframe. If it turns out we need to reset, we could handle both in-process and OOP iframe in bug 582459.

Moving it to M6c since all Fission test re-enablement is tracked in M6c.

Status: NEW → ASSIGNED
Fission Milestone: M7 → M6c

Test has enabled in bug 582459.

Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 582459
You need to log in before you can comment on or make changes to this bug.