oblong ico file not draw excactly

RESOLVED DUPLICATE of bug 160975

Status

()

Core
ImageLib
--
trivial
RESOLVED DUPLICATE of bug 160975
15 years ago
15 years ago

People

(Reporter: Hidehiro Kozawa, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
xoip.ico is oblong ico file.
acording to MS, ico file must be square.
but IE can draw oblong ico file.
xoip.ico is 62x64.
IE draw 62x64 xoip.ico exactly.
mozilla does not draw it exactly.
Which build are you using?  (Always say this, please!).  This was fixed recently...
Summary: oblong ico file not draw excactly → oblong ico file not draw excactly
(Reporter)

Comment 2

15 years ago
sorry...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020902
If it was fixed in more recently mozilla, It's dup...

I know that crash bug was fixed.
http://bugzilla.mozilla.org/show_bug.cgi?id=159256

but draw not exactly.
Look xoip.ico some icon editor or IE, You know mozilla does not draw it exactly.
imagelib.
Assignee: asa → pavlov
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Ever confirmed: true
QA Contact: asa → tpreston
Created attachment 97547 [details]
the icon

attaching the icon here
I believe a part of this bug is bug 160975

however... I think we should use the 32x32 version of the icon, which is
contained in this file as well...

right, the patch on bug 160975 fixes this.

will look into the 32x32 issue now...
right, the patch on bug 160975 fixes this.

will look into the 32x32 issue now... I actually meant 16x16 not 32x32

ok. I see the problem. if an icon with a high color depth comes before the first
16x16 icon, we're still using the high-color icon (high-color != 16bit in this case)
grrr. don't know what I was thinking... the file does not have a 16x16 version.
so our behaviour is probably ok, with the patch from bug 160975.

marking duplicate.

*** This bug has been marked as a duplicate of 160975 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.