Crash in msgimap [@ nsImapProtocol::HandleMessageDownLoadLine]

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: iann_bugzilla, Assigned: Bienvenu)

Tracking

({crash, regression, topcrash})

Trunk
x86
Windows XP
crash, regression, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Using BuildID 2002083108 on WinXP connecting to NS Messenger 4.15
I was clicking from one folder to another quite quickly when mozilla crashed.


MS Report gave this as the signature
AppName: mozilla.exe	 AppVer: 1.1.0.0	 ModName: msgimap.dll
ModVer: 1.1.0.0	 Offset: 0000820f

TBID TB10245821K
(Reporter)

Updated

16 years ago
Keywords: crash, regression, stackwanted
(Reporter)

Comment 1

16 years ago
might be related to bug 162342
Severity: normal → critical

Updated

16 years ago
Whiteboard: [has talkback ID] TB10245821K

Comment 2

16 years ago
Created attachment 97523 [details]
talkback data

Comment 3

16 years ago
Bug seems to be fixed (not yet verified). Was fixed around the same time as your
build id.

*** This bug has been marked as a duplicate of 164798 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

16 years ago
if this is happening in the 08/31 build, then I didn't fix it. I'll reopen this
one, since it has the start of steps to reproduce the problem. I was not able to
reproduce it by clicking quickly through folders, however.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Whiteboard: [has talkback ID] TB10245821K
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Summary: Crash in msgimap → Crash in msgimap [@ nsImapProtocol::HandleMessageDownLoadLine]
(Assignee)

Comment 5

16 years ago
Created attachment 97607 [details] [diff] [review]
(remotely) possible fix

we should be resetting this index when we finish downloading headers. I thought
there might be some sort of boundary condition when we download 9 headers or
so, then download another one. I could not reproduce the problem based on this
theory, but I'd like to check this fix in anyway, because it's the only thing I
can find wrong at the moment and it can't hurt.
(Assignee)

Comment 6

16 years ago
taking
Assignee: mscott → bienvenu
Status: ASSIGNED → NEW
Comment on attachment 97607 [details] [diff] [review]
(remotely) possible fix

r=sspitzer
Attachment #97607 - Flags: review+
(Assignee)

Comment 8

16 years ago
last patch checked in - will keep looking at talkback reports.

Comment 9

16 years ago
The last incident in talkback was on 09/03 so it looks like this is fixed. 
http://www.people.fas.harvard.edu/~dbaron/mozilla/talkback10

(Assignee)

Comment 10

16 years ago
talkback shows this crash:

 2002090408   MozillaTrunk   Linux 2.4.18   2002-09-08 09:33:15  
nsImapProtocol::HandleMessageDownLoadLine() 2eb66188

so it's probably still around :-( it might be getting better

Comment 11

16 years ago
It makes it to the Trunk topcrash lists. Marking it a topcrash so that we can
track it in the reports. Sorry I'm not seeing specific steps for this one, David.
Keywords: topcrash
(Assignee)

Comment 12

16 years ago
marking fixed. It's been 6 days since a daily build has shown this crash. So
unless we're just not getting talkback reports, I'm hopeful that this is fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
Used 20020912 trunk build on Win2K.
Quickly clicking through folders doesn't crash for me.

Marked Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsImapProtocol::HandleMessageDownLoadLine]
You need to log in before you can comment on or make changes to this bug.