bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Very strange clipboard crash

VERIFIED DUPLICATE of bug 166056

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 166056
16 years ago
13 years ago

People

(Reporter: Shark Daddy (Jonathan L.), Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
At the given URL, when the last line of text ("Allow transparency...")of the
post is copied and pasted into the Reply field, Mozilla immediately crashes. In
addition, the clipboard data is flushed. This occured again on every attempt to
reproduce the bug, and the Talkback ID of one of the reproductions is
TB10257488W. Running Win2k Advanced Server with 2002090208 (trunk).

Comment 1

16 years ago
may be bug 166056.
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: [has talkback ID] TB10257488W

Comment 2

16 years ago
Boris, can you check Talkback data TB10257488W ?
MSVCRT.DLL + 0x124c (0x7800124c)
nsDataObj::GetText
[c:/builds/seamonkey/mozilla/widget/src/windows/nsDataObj.cpp, line 705]
nsDataObj::GetData
[c:/builds/seamonkey/mozilla/widget/src/windows/nsDataObj.cpp, line 247]
ole32.dll + 0x4e0df (0x77a9e0df)
FillSTGMedium [c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp,
line 366]
nsClipboard::GetNativeDataOffClipboard
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 394]
nsClipboard::GetDataFromDataObject
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 577]
nsClipboard::GetNativeClipboardData
[c:/builds/seamonkey/mozilla/widget/src/windows/nsClipboard.cpp, line 826]
nsBaseClipboard::GetData
[c:/builds/seamonkey/mozilla/widget/src/xpwidgets/nsBaseClipboard.cpp, line 130]
nsPlaintextEditor::Paste
[c:/builds/seamonkey/mozilla/editor/libeditor/text/nsPlaintextDataTransfer.cpp,
line 567]
nsPasteCommand::DoCommand
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditorCommands.cpp, line 327]
nsControllerCommandManager::DoCommand
[c:/builds/seamonkey/mozilla/embedding/components/commandhandler/src/nsControllerCommandManager.cpp,
line 190]
nsEditorController::DoCommand
[c:/builds/seamonkey/mozilla/editor/libeditor/base/nsEditorController.cpp, line 209]
nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp, line 328]
DoKey [c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLKeyHandler.cpp, line 108]
nsXBLKeyHandler::KeyPress
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLKeyHandler.cpp, line 124]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1615]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2055]
nsHTMLTextAreaElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLTextAreaElement.cpp,
line 734]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6107]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6030]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2046]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 301]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1903]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2886]
nsWindow::OnChar [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 3066]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3712]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]
USER32.dll + 0x2a290 (0x77e3a290)
USER32.dll + 0x45b1 (0x77e145b1)
USER32.dll + 0x5b1d (0x77e15b1d)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1529]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1880]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1898]
WinMainCRTStartup()
KERNEL32.DLL + 0x1ca90 (0x77e9ca90) 

*** This bug has been marked as a duplicate of 166056 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Whiteboard: [has talkback ID] TB10257488W

Comment 4

16 years ago
--> verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.