Closed Bug 1662350 Opened 1 year ago Closed 1 year ago

UTF-8 newsgroups broken in TB 81 beta 2

Categories

(MailNews Core :: Networking: NNTP, defect)

Thunderbird 81
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bugzilla, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Create a news account at news.newsfan.net and try to subscribe.

Actual results:

Newsgroup display garbled in TB 81

Expected results:

Should have displayed correctly.

Attached image Display OK in TB 78.png

This is not broken in TB 81 beta 1, so the regression windows is this:
https://hg.mozilla.org/releases/comm-beta/pushloghtml?fromchange=8d8b20cab698&tochange=41a527364b27
Could be from bug 1658890.

Summary: UTF-8 newsgroups broken in TB 81 beta → UTF-8 newsgroups broken in TB 81 beta 2
Attached image newsfan.net.png

Works for me (current trunk).

(In reply to p≡p Project from comment #0)

Create a news account at news.newsfan.net and try to subscribe.

UTF-8 newsgroups broken in TB 81 beta 2

No, that Server isn't an UTF-8 server.
Unsubscribe from the groups.
Go to the server settings and select Chinese Simplified (GBK)
Then refresh the group list.

Posting to true UTF-8 Groups works for me also.
But posting to newsfan is indeed broken (but: Bug 1389762 Comment 22 !?).

(In reply to Alfred Peters from comment #3)

Create a news account at news.newsfan.net and try to subscribe.
Go to the server settings and select Chinese Simplified (GBK)

But posting to newsfan is indeed broken (but: Bug 1389762 Comment 22 !?).

At least on Trunk because of Bug 862292 ```Use UTF-8 for all outgoing email````

Hmm, Test.UTF8.测试1 isn't a UTF-8 encoded newsgroup? Do you have a better server with a "true UTF-8" group? Testing with TB 81 beta 1 and 2 again, both seem to work now. However, something wasn't right in attachment 9173294 [details]. I see it now, when initially adding the server, it got added with "Western" (ISO-8859-1, windows-1252).

Looks like this is invalid, sorry about the noise.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

(In reply to p≡p Project from comment #5)

Hmm, Test.UTF8.测试1 isn't a UTF-8 encoded newsgroup?

Indeed. To get the name correct, you have to set the default to UTF-8.

Do you have a better server with a "true UTF-8" group?

See Bug 1516774 for an example. But if I remember correct it is read only.

Testing with TB 81 beta 1 and 2 again, both seem to work now. However, something wasn't right in attachment 9173294 [details]. I see it now, when initially adding the server, it got added with "Western" (ISO-8859-1, windows-1252).

Yes, an old story: Bug 1516774 Comment 1

I assume using quoted-printable (mail.strictly_mime) would be a solution for groups that refuse to handle UTF-8 content, if there are such groups out there.

You need to log in before you can comment on or make changes to this bug.