Closed Bug 1662434 Opened 3 months ago Closed 2 months ago

sheets of paper not updated when switching destination to "Save to PDF"

Categories

(Toolkit :: Printing, defect, P2)

defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox82 --- verified
firefox83 --- verified

People

(Reporter: mbalfanz, Assigned: mstriemer)

References

(Regressed 1 open bug)

Details

(Whiteboard: [print2020_v82] )

Attachments

(1 file)

STR:

  1. Open the print dialog on any page
  2. Select a physical printer as destination
  3. Change the number of copies to something other than 1
  4. Switch change the destination to "Save to PDF"

ER: The number of pages should shown in the top right corner should reflect the length of document as if it was only 1 copy
AR: The number of pages in the top right corner shows the total number of sheets as if the physical printer was still selected

Thinking about it, for "Save to PDF" we may not want to show "Sheets of paper" at all. Or we could show the number of pages instead, which might be good when selecting a custom range.

Priority: -- → P2

(This may also get fixed when we fix bug 1662331…)

This is because we don't change the numCopies setting when the printer changes. We do the sheetCount * numCopies calculation on our own, so using sheetCount directly here won't help us.

We could update the PrintSettingsViewProxy to dynamically return a value for numCopies, so something like this.get(target, "willSaveToFile") ? 1 : target.numCopies. It might be better to reset numCopies when the printer changes if the new printer is a PDF printer though, since if we don't reset numCopies we'll still ask the PDF printer to print that many copies.

Hi Mike,
could you please in setting a severity value for this ticket?

Flags: needinfo?(mconley)

(And this. In general I can do the priority/severity for stuff in Toolkit::Printing for the next few releases, so that we don't bother Mike. 😉)

Severity: -- → S4
Flags: needinfo?(mconley)

Understood :) Thanks for updating it.

Whiteboard: [print2020_v81] → [print2020_v82]
Assignee: nobody → mstriemer
Status: NEW → ASSIGNED
Blocks: 1664565
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/397260e89398
Show correct sheet count for PDF printers when numCopies is set r=emalysz
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Regressions: 1665419
Flags: qe-verify+

I managed to reproduce the issue on an older version of Nightly.
I retested everything using latest Nightly 83.0a1 and Firefox 82.0b2 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.