Listed URL causes apprunner to crash

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: ltskinol, Assigned: vidur)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

294 bytes, text/html
Details
(Reporter)

Description

19 years ago
The (female) masses need this one fixed!

I do know that eBay uses several giant HTML forms on this page.  Perhaps
that's the problem.

The bug occurs in the Linux release of M10, on a standard RedHat 6.0
install.  It seems to still be there as of the CVS version of two
days ago.

Comment 1

19 years ago
*** Bug 16627 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
Crash replicated with 1999-10-17-09-M11 on Windows NT.

URL begins loading, some content is displayed, and then CRASH.

Could this matter:  part of the content that did come up
said something to the effect of "You must be an EBAY member to sell..."
If the EBAY cgi is assuming that nobody will view this page without
having signed up, this could be a cookie problem.

Comment 3

19 years ago
Created attachment 2242 [details]
testcase

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 4

19 years ago
Added a testcase that crashes M10 on Win95, haven't tested on more recent builds
or other platforms.

The page has a huge JavaScript-enhanced form that seems to be causing the crash.
The problem appears when options are added to SELECT fields in the form, which
is what the testcase does. Moving the script out of the form (in the testcase)
gets rid of the crash, but the results still aren't what you would expect:
Instead of getting a new option "foo", an "X" appears, at least on my config.

Updated

19 years ago
Assignee: don → vidur
Component: Browser-General → DOM Level 0
OS: Linux → All
Hardware: PC → All

Comment 5

19 years ago
Changing platform=os=all and component=DOM 0 and reassigning.

Comment 6

19 years ago
Checked testcase on Linux (RH6.0) with M10 and 1999102109 builds. M10 crashed on
loading, but the 1999102109 build worked fine.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

19 years ago
Also works correctly on 1999-11-06-08-M11 on Win NT.
No crash on load or while exercising the form; form works except for
annoying display problem as the javascript updates the <selects> (bug 18189).

Updated

19 years ago
QA Contact: leger → desale

Comment 8

19 years ago
Resetting QA contact from leger.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Verified with 1999-11-22-09.
You need to log in before you can comment on or make changes to this bug.