Closed Bug 1662703 Opened 2 months ago Closed 2 months ago

[css-ui] Change appearance: button to only apply to buttons

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: mozilla-apprentice, Assigned: emilio)

References

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

A resolution was made for csswg-drafts/#5174.

[css-ui] Change appearance: button to only apply to buttons

  • RESOLVED: Limit 'appearance: button' to buttons once we figure out what buttons are

Discussion.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Duplicate of this bug: 1652899
Keywords: dev-doc-needed
See Also: → 1663540

The protections.css declaration is not needed, because you're setting
backgrounds and borders anyways so native appearance is disabled.

The button.css change needs to turn into a -moz-default-appearance +
appearance combo, but since it's in three different places, just put it
in xul.css instead.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56e1f7f0268b
Tweak appearance: button usage in browser/ and toolkit/. r=dao
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/baab244deeb0
Make appearance: button behave like auto. r=heycam
Failed to create upstream wpt PR due to merge conflicts. This requires fixup from a wpt sync admin.
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Status: RESOLVED → REOPENED
Flags: needinfo?(emilio)
Resolution: FIXED → ---
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a3863563468
Make appearance: button behave like auto. r=heycam
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/25576 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot

The BCD has already been merged for this, so I've just added a note in the 82 release notes.

Regressions: 1672165
You need to log in before you can comment on or make changes to this bug.