Closed Bug 1662818 Opened 1 year ago Closed 1 year ago

System modal has the “All” radio button selected even if a custom page range was set from the new UI

Categories

(Toolkit :: Printing, defect, P2)

defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- disabled
firefox82 --- verified

People

(Reporter: emilghitta, Assigned: emalysz)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [print2020_v82][old-ui-])

Attachments

(2 files)

Attached image ModalAll.gif

Affected versions

  • 82.0a1 (BuildId:20200902095359)
  • 81.0b5 (BuildId:20200901203141)

Affected platforms

  • Windows 10 64bit
  • Ubuntu 18.04 64bit (I will get back with a confirmation on Ubuntu tomorrow, marking this as affect until then).

Unaffected platforms

  • macOS 10.14

Steps to reproduce

  1. Launch Firefox.
  2. Access the following link
  3. Hit Ctrl + P
  4. Select a physical printer and set a custom range between 1 and 2 (out of 3 total pages).
  5. Click the “Print using the system dialog” option.
  6. Print the page via the system dialog.

Expected result

  • The System dialog opens and the Pages radio button from the “Page Range” section is selected (because a custom range has been selected in the UI) and the page range from the system modal reflects the values from the new UI.

Actual result

  • The System dialog opens and the All radio button is selected from the “Page Range” section. The page range from the system modal reflects the values from the new UI but having the “All” radio button selected will go ahead and print all the pages.

Regression Window

Additional Information

  • For further information regarding this issue please observe the attached screencast.
  • Setting the ALL platforms for now until I get a confirmation that Ubuntu is affected as well.
  • [Suggested Severity] S3

Hi Emma!

It seems that mozregression pointed out Bug 1653389, show error if page range input is invalid r=fluent-reviewers,sfoster,flod for causing this regression.

I can see that Bug 1661852 has the same output but that's a little bit different since I think that covers a different scenario.

Can you please take a look?

Thank you!

Flags: needinfo?(emalysz)
Severity: -- → S3
Priority: -- → P2

I think this may be covered in Bug 1661852, but I'll have to double check

I can still reproduce this issue using Firefox 82.0a1 (BuildId:20200903094553). (Bug 1661852 has landed in m-c)

Has Regression Range: --- → yes
Has STR: --- → yes
Whiteboard: [print2020_v81] [old-ui-] → [print2020_v82][old-ui-]
See Also: → 1660929
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7117f0f30770
select pages radio button from system dialog if custom range is specified r=emilio
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Flags: needinfo?(emalysz)
Flags: qe-verify+

Reproduced the initial issue using old Nightly (2020-09-02), verified that this is fixed in Firefox 82.0b3 on Windows 10 and Ubuntu 18.04 but not in macOS 10.15.7.
I also see this issue with Chrome as well. Could it be that this is intended not to work on MacOS?

Flags: needinfo?(emalysz)

No, this should still work on MacOS. I'm seeing it work in my local build, but it doesn't seem to work on Nightly.. I'll look into this

See Also: → 1668894

I filed 1668894 for macOS. That seems to occur for changing settings when "Save to pdf" is the selected printer.

Flags: needinfo?(emalysz)

Got it, I'll close this bug as verified and track the remaining work for macOS in bug 1668894.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

I can still reproduce this issue using Nightly 93.0a1 on Ubuntu 18.04 x64.

Flags: needinfo?(emalysz)

If you input a specific custom range into the field, then it should switch to "custom".
However, if no range is inputted with custom selected, it'll still show as all. This should be addressed in bug 1660929

Flags: needinfo?(emalysz)

I used a valid range and then clicked on “Print using the system dialog” option. The only difference from the STR in comment 0 is that I used "Save to Pdf" option. The issue is not reproducing while using a physical printer.

You need to log in before you can comment on or make changes to this bug.