Mozilla mail silently deletes Netscape 4 IMAP trash folder

RESOLVED INVALID

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Jim Laurent, Assigned: Scott MacGregor)

Tracking

({dataloss})

Trunk
PowerPC
Mac OS X
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0
Build Identifier: 20020826 

When using Mozilla mail 1 day after using netscape mail against the same IMAP
mail server, Mozilla deletes the trash folder and starts with a blank one.

LOSS of DATA.

Reproducible: Always

Steps to Reproduce:
1. Run Netscape 4.79 at work and delete some mail into the Trash
2. Run Mozilla 1.1 from home against the same mail folder
3. Click on IMAP Trash folder.  List shows 0 entries
4. Delete some mail.  Mozilla starts trash again at 1 entry

Actual Results:  
Trash silently was deleted by Mozilla

Expected Results:  
Trash mailbox should be maintained across multiples runs of Mozilla/Netscape 4
over multiple days.

Mozilla should never silently deletel mail.

Appears to be similar with Mozilla for Solaris.

Using both on the same day does not appear to cause the problem. Only after a
day rollover.

Updated

16 years ago
Keywords: dataloss

Comment 1

16 years ago
Jim, are you sure you have both Netscape 4 and Mozilla configured to move
deleted messages to the Trash for that account?
(Reporter)

Comment 2

16 years ago
Yes.  Both are configured for move messages to trash upon deletion.  Both
succesfully move message to trash, but in the case of Mozilla, the first message
moved to the trash one day after Netscape accessed it causes silent deletion of
the Trash file.  I've confirmed this with ls -l showing a size of zero.

When I go back to work and click on Trash folder, I get a message from Netscape
4 to the effect of "Mailbox shrunk from size xxxx bytes to zero bytes."

FYI. IMAP Mail server info.

Solstice (tm) Internet Mail Server (tm) 2.0p12 IMAP4 service 

(Yes I know it's ancient.)

Sample Header of the Trash file as kept by Netscape 4.

From <IMAP4.pseudo.sims> Tue Sep  3 10:43:04 2002
Date: Tue, 3 Sep 2002 10:43:04 -0400 (EDT)
From: Postmaster
Subject: IMAP4 Server Data-DO NOT DELETE
Content-Length: 94
Mime-Version: 1.0
Status: RO
X-IMAP: 1031050942 163

This message is from the IMAP server.
VERY IMPORTANT Server DATA.













--END+PSEUDO--

Comment 3

16 years ago
WorksForMe using FizzillaCFM/2002083017 on 10.1.5 and Netscape Communicator 4.8.
(Reporter)

Comment 4

16 years ago
Could it be the old IMAP server that we're using is not reponsding to requests
properly?

What kind of mail conversation trace would be most helpful?  tcpdump on OS X?

Comment 5

16 years ago
Jim, I'd suggest testing using another IMAP server, such as a free mac.com trial
account.
(Reporter)

Comment 6

16 years ago
I was unable to reproduce this problem using the .mac IMAP mail service.  I
guess we'll have to chalk it up to nastiness involving Netscape 4 and SIMS 2.
(Reporter)

Comment 7

16 years ago
This problem also occurs when using Netscape 7 (Solaris) at work and
Mozilla/Netscape 7 at home.  Problem seems to be that Mozilla updates the Trash
header only when you click to view that folder.  In this case the X-IMAP line
indicates 41 messages in the trash.

Problem occurs when I leave Mozilla running at one site overnight.  It's
checking for mail automatically and filtering some items to the trash.  There
are items in the trash but the X-IMAP line has not been updated.

I log in from home the next morning (while Moz is still running at work) and Moz
at home must be confused about the trash because the first time it puts
something in, it (or the IMAP server) deletes the trash.  Moz then reports
"Mailbox shrunk from xxxx bytes to 0 bytes."

Help me a little bit here.  Should an IMAP server support concurrent access to
multiple mailboxes?  Why does this only occur with Trash and not with Sent?  My
Sent box is also accessed from both sites and has never been deleted.  What is
the proper behavior of the IMAP server in this case?


head Trash
From <IMAP4.pseudo.sims> Tue Sep 10 07:50:00 2002
Date: Tue, 10 Sep 2002 07:50:00 -0400 (EDT)
From: Postmaster
Subject: IMAP4 Server Data-DO NOT DELETE
Content-Length: 94
Mime-Version: 1.0
Status: RO
X-IMAP: 1031657417 41

This message is from the IMAP server.
(Reporter)

Comment 8

16 years ago
Turns out that our IT Nazis have a cron job that every night cats /dev/null into
HOME/Trash, Mail/Trash and .dt/Trash. .

Please feel free to close this bug.  Sorry for the trouble.

Comment 9

16 years ago
Resolving Invalid per reporter. Thanks, Jim.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.