Closed Bug 1663465 Opened 4 months ago Closed 4 months ago

Intermittent [TCw] TEST-UNEXPECTED-CRASH | /input-events/input-events-get-target-ranges-backspace.tentative.html | expected OK

Categories

(Core :: DOM: Events, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1663968

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=315004135&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/LsICGlQiQ5iaK49X-vBfSQ/runs/0/artifacts/public/logs/live_backing.log


[task 2020-09-07T11:57:14.379Z] 11:57:14 INFO - TEST-START | /input-events/input-events-get-target-ranges-backspace.tentative.html
[task 2020-09-07T11:57:14.399Z] 11:57:14 INFO - Setting pref dom.input_events.beforeinput.enabled (true)
[task 2020-09-07T11:57:14.437Z] 11:57:14 INFO - PID 592 | [CodeCoverage] Requested flush for 3416.
[task 2020-09-07T11:57:16.107Z] 11:57:16 INFO - PID 592 | [CodeCoverage] flush completed.
[task 2020-09-07T11:57:16.471Z] 11:57:16 INFO - PID 592 | [CodeCoverage] JS flush completed.
[task 2020-09-07T11:57:16.471Z] 11:57:16 INFO - PID 592 | [CodeCoverage] Requested flush for 8084.
[task 2020-09-07T11:57:16.472Z] 11:57:16 INFO - PID 592 | [CodeCoverage] Requested flush for 9840.
[task 2020-09-07T11:57:16.472Z] 11:57:16 INFO - PID 592 | [CodeCoverage] Requested flush for 8688.
[task 2020-09-07T11:57:16.472Z] 11:57:16 INFO - PID 592 | [CodeCoverage] Requested flush for 5652.
[task 2020-09-07T11:57:22.348Z] 11:57:22 INFO - PID 592 | [CodeCoverage] flush completed.
[task 2020-09-07T11:57:22.367Z] 11:57:22 INFO - PID 592 | [CodeCoverage] JS flush completed.
[task 2020-09-07T11:57:27.985Z] 11:57:27 INFO - PID 592 | [CodeCoverage] flush completed.
[task 2020-09-07T11:57:28.004Z] 11:57:28 INFO - PID 592 | [CodeCoverage] JS flush completed.
[task 2020-09-07T11:57:34.041Z] 11:57:34 INFO - PID 592 | [CodeCoverage] flush completed.
[task 2020-09-07T11:57:34.066Z] 11:57:34 INFO - PID 592 | [CodeCoverage] JS flush completed.
[task 2020-09-07T11:57:39.715Z] 11:57:39 INFO - PID 592 | [CodeCoverage] flush completed.
[task 2020-09-07T11:57:39.715Z] 11:57:39 INFO - PID 592 | [CodeCoverage] JS flush completed.
[task 2020-09-07T11:57:40.567Z] 11:57:40 INFO - {'actions': [{u'type': u'none', u'id': u'0', u'actions': [{u'duration': 16, u'type': u'pause'}, {u'duration': 16, u'type': u'pause'}]}, {u'type': u'key', u'id': u'1', u'actions': [{u'type': u'keyDown', u'value': u'\ue003'}, {u'type': u'keyUp', u'value': u'\ue003'}]}]}
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | 1599479860681 Marionette WARN TimedPromise timed out after 16 ms: stacktrace:
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | TimedPromise/<@chrome://marionette/content/sync.js:243:19
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | TimedPromise@chrome://marionette/content/sync.js:228:10
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | Sleep@chrome://marionette/content/sync.js:281:10
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | dispatchPause@chrome://marionette/content/action.js:1478:10
[task 2020-09-07T11:57:40.687Z] 11:57:40 INFO - PID 592 | toEvents/<@chrome://marionette/content/action.js:1152:16
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | action.dispatchTickActions@chrome://marionette/content/action.js:1056:35
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | action.dispatch/chainEvents<@chrome://marionette/content/action.js:1024:20
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | action.dispatch@chrome://marionette/content/action.js:1030:5
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | performActions@chrome://marionette/content/listener.js:849:16
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | dispatch/</req<@chrome://marionette/content/listener.js:522:14
[task 2020-09-07T11:57:40.688Z] 11:57:40 INFO - PID 592 | dispatch/<@chrome://marionette/content/listener.js:515:15

[task 2020-09-07T11:57:44.383Z] 11:57:44 INFO - PID 592 | action.dispatch/chainEvents<@chrome://marionette/content/action.js:1024:20
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - Traceback (most recent call last):
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 729, in run_func
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - self.result = True, self.func(self.protocol, self.url, self.timeout)
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 842, in do_testharness
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - self.script_resume % format_map, asynchronous=True)
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 87, in execute_script
[task 2020-09-07T11:57:44.430Z] 11:57:44 WARNING - return method(script, new_sandbox=False, sandbox=None)
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1652, in execute_async_script
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - rv = self._send_message("WebDriver:ExecuteAsyncScript", body, key="value")
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\venv\lib\site-packages\marionette_driver\decorators.py", line 26, in _
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - return func(*args, **kwargs)
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\venv\lib\site-packages\marionette_driver\marionette.py", line 594, in _send_message
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - msg = self.client.request(name, params)
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\venv\lib\site-packages\marionette_driver\transport.py", line 276, in request
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - return self.receive()
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - File "Z:\task_1599477118\build\venv\lib\site-packages\marionette_driver\transport.py", line 169, in receive
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - if len(remaining) == int(length):
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING - ValueError: invalid literal for int() with base 10: 'null,{"value"'
[task 2020-09-07T11:57:44.431Z] 11:57:44 WARNING -
[task 2020-09-07T11:57:44.436Z] 11:57:44 INFO - Browser not responding, setting status to CRASH
[task 2020-09-07T11:57:44.440Z] 11:57:44 INFO - TEST-UNEXPECTED-CRASH | /input-events/input-events-get-target-ranges-backspace.tentative.html | expected OK
[task 2020-09-07T11:57:44.440Z] 11:57:44 INFO - TEST-INFO took 30062ms
[task 2020-09-07T11:57:44.440Z] 11:57:44 INFO - No more tests
[task 2020-09-07T11:58:55.568Z] 11:58:55 INFO - Browser exited with return code 572
[task 2020-09-07T11:58:55.569Z] 11:58:55 INFO - PROCESS LEAKS None
[task 2020-09-07T11:58:55.569Z] 11:58:55 INFO - Closing logging queue
[task 2020-09-07T11:58:55.569Z] 11:58:55 INFO - queue closed
[task 2020-09-07T11:58:55.570Z] 11:58:55 INFO - PROCESS LEAKS None
[task 2020-09-07T11:58:55.640Z] 11:58:55 INFO - Got 1 unexpected results
[task 2020-09-07T11:58:55.640Z] 11:58:55 INFO - SUITE-END | took 111s
[task 2020-09-07T11:58:55.680Z] 11:58:55 INFO - Removed font: Ahem.ttf
[task 2020-09-07T11:58:55.690Z] 11:58:55 INFO - Closing logging queue
[task 2020-09-07T11:58:55.691Z] 11:58:55 INFO - queue closed
[task 2020-09-07T11:58:55.815Z] 11:58:55 ERROR - Return code: 1
[task 2020-09-07T11:58:55.850Z] WARNING: No valid records found in []

There is no stack trace... And according to the other odd intermittent failures, does our test driver have something unstable for synthesizing key events?

looks like that this is also a timeout log, not actual crash.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1663968
You need to log in before you can comment on or make changes to this bug.