Closed Bug 1663630 Opened 1 year ago Closed 1 year ago

Remove default topsites that match the current default engine, even if specified in the topsites collection

Categories

(Firefox :: Top Sites, defect, P3)

Firefox 81
defect
Points:
1

Tracking

()

RESOLVED FIXED
83 Branch
Iteration:
83.1 - Sept 21 - Oct 4
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- fixed

People

(Reporter: aflorinescu, Assigned: dao)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

[Sugested Severity:]

S3

[Description:]

See https://bugzilla.mozilla.org/show_bug.cgi?id=1663179#c3

[Environment:]

Windows 10
81.0b7 20200906164749

[Steps:]
  1. Add https://baidu.com as a topsite in the Remote Settings configuration.
  2. From the Remote Settings configuration, set the https://baidu.com to be a search shortcut.
  3. Publish the changes and set Firefox to connect to the respective collection.
  4. Set a Firefox profile to connect to the configuration while switching the browser.topsites.useRemoteSetting to true and setting browser.search.region to CN
  5. Download a zh-CN build and setart Firefox with the previously prepared profile.
  6. Start-up Firefox with the above profile configuration.
  7. From about:preferences#search change the default search engine to something else than baidu.
  8. From about:preferences#search change the default search engine back to baidu.
[Actual Result:]
  1. default engine: baidu ; Topsite: baidu - not pinned, not search shortcut marked.
  2. default engine: not_baidu; Topsite: baidu - pinned, search shortcut marked.
  3. default engine: baidu; Topsite: baidu - pinned, search shortcut marked.
[Expected Result:]
  1. default engine: baidu ; Topsite: baidu is not listed in the topsites
  2. default engine: not_baidu; Topsite: baidu - pinned, search shortcut marked.
  3. default engine: baidu; Topsite: baidu is not listed in the topsites
Severity: -- → S3
Priority: -- → P3
Priority: P3 → P5
Severity: S3 → S2
Priority: P5 → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 83.1 - Sept 21 - Oct 4
Points: --- → 1
Flags: qe-verify+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe4ea14764c6
Remove default topsites that match the current default engine, even if specified in the topsites collection. r=mikedeboer
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

This fix is not complete, in the sense that with comment 0 steps, it will still reproduce. If the topsite matches the default search engine and the topsite is set as a search shortcut, then on the engine switch away from default, the topsite will become pinned -> this causes the switch back to the default engine to not be able to remove the topsite, since it is pinned.

to exemplify, taking in account the earlier discussion related to the legacy hardcoded @google search shortcuts:

  • if we have google.com set as a topsite for everyone, the locales/regions that have @google as default engine, will not have google.com topsite and when switching away from google, it will display google.com as topsite, then switching back to default engine google will hide it away again (repeat works).

  • if we have google.com set as a search shortcut topsite for everyone, the locales/regions that have @google as default engine, will not have google.com search shortcut topsite and when switching away from google, it will display search shortcut google.com as topsite (which is pinned) - and switching back to google won't hide it.

See Also: → 1674270
See Also: → 1677076
You need to log in before you can comment on or make changes to this bug.