Closed Bug 1663857 Opened 1 year ago Closed 1 year ago

Manage Pioneer v2 consent in about:pioneer

Categories

(Firefox :: Pioneer, task, P1)

task

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox81 + fixed
firefox82 --- fixed

People

(Reporter: Dexter, Assigned: Dexter)

References

(Blocks 1 open bug)

Details

Attachments

(6 files)

This is for implementing the spec from this document.

It includes:

  • Creating a new ping;
  • adding user consent timestamp to this ping
  • deploying the new schema;
  • adding test coverage.
Blocks: 1634552

I had a nice conversation with Anthony. We have a few options, and which one to pick really depends on how we want to look at the data.

The consent for joining the specific study can be easily dispatched to the table that contains the data for that study (as we do for the deletion-request).

The consent for joining the pioneer program itself is a bit harder: we currently don't have any dataset for general "pioneer metadata" allocated. We either need to:

A) Allocate a new dataset for "general pioneer metadata", which means we'd need to set a new schemaNamespace in Firefox itself. In this case, we wouldn't need to ship new public keys (please Anthony correct me if I'm wrong): our payload is empty.
B) Use the "core addon" dataset, adding the consent data to the other data in this table. This means shipping the addon public keys in Firefox (a bit awkward). This also means that, if we ever share "core addon data" with partners, they'd access this data as well.

Ted, what do we intend to do? Assuming there's no objection to the specific study consent as described above, how do we want to handle the general consent? A or B?

Flags: needinfo?(ted)

To retain consistency with what we're doing with the deletion pings, I'd like to pursue what you've laid out as path A

Flags: needinfo?(ted)

This introduces the enrollment ping (really the existing 'ping-study'
ping with a different schema name) that is sent both when user joins
Pioneer and when they join a new study.

The one sent when joining pioneer has a different namespace, because
we want this data to flow in a separate dataset. The one sent when
joining the study behaves like the deletion-request, has an empty
payload and is properly routed to the study table due to the rules
on the pioneer ingestion pipeline.

This additionally lands documentation required for data-review.

Hey Chris,

this data review is for a pioneer-study ping with an empty payload. We'll be looking at the creation date of the ping to determine when users enroll in Pioneer and in specific studies.

Attachment #9174882 - Flags: data-review?(chutten)

Comment on attachment 9174882 [details]
pioneer-enrollment-request.md

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Ted Han is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

Is the data collection request for default-on or default-off?

Default off for all channels. Users must opt in to Pioneer.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.


Result: datareview+

Attachment #9174882 - Flags: data-review?(chutten) → data-review+
Pushed by aplacitelli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8872cde42a12
Introduce the Pioneer enrollment ping. r=rhelmer
https://hg.mozilla.org/integration/autoland/rev/f1dd8a993206
Ensure pioneer pings are properly routed to the study tables. r=rhelmer,amiyaguchi

Alessio tells me this needs to land on 81 prior to the RC build.

Alessio, there are multiple attachments in this ticket. Can you let me know which of these (or both) require uplift?

Flags: needinfo?(alessio.placitelli)
See Also: → 1664286

(In reply to Marnie Pasciuto-Wood [:marnie] from comment #10)

Alessio, there are multiple attachments in this ticket. Can you let me know which of these (or both) require uplift?

Hey Marnie, this attachment (the one on Phabricator) is the only one to uplift.

Flags: needinfo?(alessio.placitelli)
Pushed by aplacitelli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8423539ca35
Introduce the Pioneer enrollment ping. r=rhelmer
https://hg.mozilla.org/integration/autoland/rev/a755410acaab
Ensure pioneer pings are properly routed to the study tables. r=rhelmer,amiyaguchi

Comment on attachment 9174982 [details]
Bug 1663857 - Ensure pioneer pings are properly routed to the study tables. r?rhelmer,amiyaguchi

Beta/Release Uplift Approval Request

  • User impact if declined: We cannot launch without this functionality, per Trust. This captures the timestamp and date of user consent for joining a specific study.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky. Adds one telemetry ping for the about:pioneer project. No risk to Firefox. Has passed data review.
  • String changes made/needed: None
Attachment #9174982 - Flags: approval-mozilla-beta?
Attachment #9174878 - Flags: approval-mozilla-beta?
Regressions: 1664481
Regressions: 1664484
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Comment on attachment 9174878 [details]
Bug 1663857 - Introduce the Pioneer enrollment ping. r?rhelmer,amiyaguchi

Approved for 81.0rc1.

Attachment #9174878 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9174982 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.