Closed Bug 1663968 Opened 3 months ago Closed 3 months ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-<any>.tentative.html

Categories

(Core :: DOM: Events, defect, P5)

defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox82 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: masayuki)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=315216101&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/R18LMN9GQvaxlGIVtWjtEg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-09-09T14:42:47.922Z] 14:42:47     INFO - TEST-PASS | /input-events/input-events-get-target-ranges-backspace.tentative.html | Meta + Backspace at "<p>abc def[] ghi</p>" 
[task 2020-09-09T14:42:47.922Z] 14:42:47     INFO - TEST-FAIL | /input-events/input-events-get-target-ranges-backspace.tentative.html | Shift + Backspace at "<p>   abc[] def</p>" - assert_equals: beforeinput.getTargetRanges() should return expected range (inputType is "deleteContentBackward") expected "(#text \"   abc def\", 10)" but got "(#text \"   abc def\", 3)"
[task 2020-09-09T14:42:47.922Z] 14:42:47     INFO - checkGetTargetRangesOfBeforeinputOnDeleteSomething@http://web-platform.test:8000/input-events/input-events-get-target-ranges-backspace.tentative.html:130:18
[task 2020-09-09T14:42:47.922Z] 14:42:47     INFO - @http://web-platform.test:8000/input-events/input-events-get-target-ranges-backspace.tentative.html:1178:53
[task 2020-09-09T14:42:47.922Z] 14:42:47     INFO - TEST-FAIL | /input-events/input-events-get-target-ranges-backspace.tentative.html | Control + Backspace at "<p>   abc[] def</p>" - assert_equals: One beforeinput event should be fired if the key operation deletes something expected 1 but got 0
[task 2020-09-09T14:42:47.923Z] 14:42:47     INFO - checkGetTargetRangesOfBeforeinputOnDeleteSomething@http://web-platform.test:8000/input-events/input-events-get-target-ranges-backspace.tentative.html:122:16
[task 2020-09-09T14:42:47.923Z] 14:42:47     INFO - @http://web-platform.test:8000/input-events/input-events-get-target-ranges-backspace.tentative.html:1205:53
[task 2020-09-09T14:42:47.923Z] 14:42:47     INFO - TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-backspace.tentative.html | Alt + Backspace at "<p>   abc[] def</p>" - Test timed out
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - TEST-INFO | expected FAIL
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - 
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - TEST-UNEXPECTED-NOTRUN | /input-events/input-events-get-target-ranges-backspace.tentative.html | Meta + Backspace at "<p>   abc[] def</p>" - expected FAIL
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - TEST-INFO | expected FAIL
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-backspace.tentative.html | expected OK
[task 2020-09-09T14:42:47.924Z] 14:42:47     INFO - TEST-INFO took 10328ms
[task 2020-09-09T14:42:47.929Z] 14:42:47     INFO - PID 2968 | 1599662567922	Marionette	INFO	Stopped listening on port 56097
[task 2020-09-09T14:42:48.607Z] 14:42:48     INFO - Browser exited with return code 0
[task 2020-09-09T14:42:48.607Z] 14:42:48     INFO - PROCESS LEAKS None
[task 2020-09-09T14:42:48.609Z] 14:42:48     INFO - .
[task 2020-09-09T14:42:48.609Z] 14:42:48     INFO - Closing logging queue
[task 2020-09-09T14:42:48.610Z] 14:42:48     INFO - .
[task 2020-09-09T14:42:48.610Z] 14:42:48     INFO - queue closed
[task 2020-09-09T14:42:48.610Z] 14:42:48     INFO - ..```

5 failures on macOS yesterday. Please take a look.

Flags: needinfo?(masayuki)
No longer regressed by: 1658702

Ah, the functions called by promise_test do not return Promise. It might be the reason why these odd results.
https://web-platform-tests.org/writing-tests/testharness-api.html#promise-tests

Testing...
https://treeherder.mozilla.org/#/jobs?repo=try&revision=46ade2aa19d7492032ba16c098a5502d23e7979f

Flags: needinfo?(masayuki)

Well, my previous comment is wrong. I see the oranges, and according to MDN, async functions return Promise implicitly.

Oh, I still don't understand what's going on, though.
The log is odd.
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=315426170&repo=try&lineNumber=7111-7224
This looks like that before finishing the test, other tests run.

Ah, it might be too short time for running all tests since the number of tests are increased.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=75059c0cb22c42718acfda53b17e6b24991d00d8

Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-backspace.tentative.html | Alt + Backspace at "<p> abc[] def</p>" - Test timed out → Intermittent TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-backspace.tentative.html | <modifyer> + Backspace at "<p> abc[] def</p>" - Test timed out
Duplicate of this bug: 1663460

Since a lot of cases are tested in the tests, they may time out when the
environment is a little bit busy. For now, we should allow them to run
longer. But adding new tests may cause timing out again. If so, we need to
split them at runtime.

Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/0af5022912bf
Allow `input-events-get-target-ranges-*.tentative.html` to run longer because they test a lot of cases r=smaug
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/25501 for changes under testing/web-platform/tests
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-backspace.tentative.html | <modifyer> + Backspace at "<p> abc[] def</p>" - Test timed out → Intermittent TEST-UNEXPECTED-TIMEOUT | /input-events/input-events-get-target-ranges-<any>.tentative.html
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.