Application crashes while browsing ebay.com. I get "invalid page fault" error message. All instances of Mozilla close if more than one is open at the time.

RESOLVED DUPLICATE of bug 153815

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 153815
16 years ago
14 years ago

People

(Reporter: Bob Lippman, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721

I have had netmail.att.net, ebay.com, my local router &/or switch internet based
control panel, and dell.com open in various combos and singly.  The browser
crashes for no apparent reason, giving the windows error msg. "invalid page
fault".  Any open browser windows open at t5he time close.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Unintentional failures.  I have now shut down Netscape 7.0 Quickstart.  Let's
see whart happens.

Expected Results:  
Remained open.

Comment 1

16 years ago
Did you submit a Talkback incident? And if so what is the incident ID#? (Run
~/[Application Folder]/components/talkback.exe).

And may I suggest a newer version. You're using Mozilla1.1Beta (by the looks of
your build ID). A lot of changes have landed since then.

Updated

16 years ago
Severity: normal → critical
Keywords: crash, stackwanted

Comment 2

16 years ago
I have also noted these crashes in Ebay... using release build 1.1 under WinXP.
 Talkback incidents #TB10360387M and TB10328879G.  I had no quickstart enabled.  
(Reporter)

Comment 3

16 years ago
I loaded The latest release (20020826).  It seemed OK.  But When I got on EBAY,
and tried setting items to be watched, it crashed.  No error messages, just shut
down the browser.  I had only one instance of Mozilla running, and no other
programs (except Mcafee's virusscan).  Netscape 7.0 and IE 6.0 do not exhibit
this problem, all things being equal.

Comment 4

16 years ago
I'm seeing similar problems on ebay, especially when I use the back button. 
2002090304 on win2k, sp3

TB10373620K
TB10373447G
TB10367239E
TB10303998Y (which may be an earlier build)

Comment 5

16 years ago
I also am seeing this with WinXP and Mozilla 1.1
talkback info:
TB10436152H
TB10436058G
TB10432957Y
TB10432849X
TB10431129Q

Brian.

Comment 6

16 years ago
I just spent over an hour on ebay testing the 2002090608 trunk build, and it did
not crash.  It used to do so consistently within a few minutes on ebay, with all
trunk builds from 1.1 release on (did not try ebay with 1.1b).  

I used the classic theme this time, rather than the slightly modified classic
theme that I have been using (built on the 1.1 release Classic), so I am not
entirely sure that it is the build that is responsible, but it seems like it WFM
now.

Comment 7

16 years ago
I just spent over an hour on ebay testing the 2002090608 trunk build, and it did
not crash.  It used to do so consistently within a few minutes on ebay, with all
trunk builds from 1.1 release on (did not try ebay with 1.1b).  

I used the classic theme this time, rather than the slightly modified classic
theme that I have been using (built on the 1.1 release Classic), so I am not
entirely sure that it is the build that is responsible, but it seems like it WFM
now.

Comment 8

16 years ago
I was seeing lots of crashes when browsing Ebay using 1.1 on both XP and Solaris.
Today's trunk build (Solaris 20020906) has been stable for at least twice
as long as I was seeing before -- still browsing and no crashing.

Comment 9

16 years ago
I have pretty much this same problem on my Linux box.  I ran it from the command
line by typing both "mozilla" and "mozilla-bin" hoping to get an error message
at the prompt, but nothing showed up.

While surfing ebay pages, I can only expect that mozilla will run for a minute
or two.  I have not had any problem with any other web page.

I am using Mozilla 1.1 compiled by me using gcc 3.2 on a Mandrake 9 rc2 system.
 It was rc1, and I was still having the same problem.

System is an Athlon XP 1900+ on a Soyo Dragon Lite Motherboard with 1GB RAM.

Comment 10

16 years ago
I am seeing this bug on both Windows 95 OSR2 and Windows NT 4.0.  Just browsing
between ebay pages and wham, mozilla crashes.  I have been submitting the
Talkbacks to Netscape (abouta half a dozen in the last week).  I wanted to
include the script of the last one here but it exceeds 64K so it is disallowed.

As a user committed to mozilla, and also a frequent user of ebay, this is very
frustrating bug for me.

Comment 11

16 years ago
Created attachment 101062 [details]
talkback dump from mozilla crash on ebay.

Okay, here's the talkback dump mentioned in my previous post.

Comment 12

16 years ago
A consistent crash producer for me over the last 36 hours:
Search item titles for "mumiy troll"
0 items come up
Click on "completed items"
2 items come up
Click into and back out of the listed items...

The crash has occurred at different points in this procedure.  Sometimes as soon
as I get into the first search listing, but sometimes later after clicking into
and back out of the links.

Comment 13

16 years ago
Yeah. What they said. Crashes when using ebay. Especially often when I hit the
back button. What gives?

TB#'s:
TB12119180K
TB12074752H

There would be a dozen or so others, but I deleted and reinstalled Moz, hoping
to fix the problem.

Comment 14

16 years ago
Just browsed ebay for an hour with 1.2a (UA: Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.2a) Gecko/20020910).  No problems whatsoever.

Comment 15

16 years ago
I've also run into this problem, using Mozilla 1.1 on XP Service Pack 1. Only
additional piece of info I have is that once in a while I also get a Visual C++
debugger message saying that the application made a pure virtual function call.
Incidentally, this only seems to happen on the ebay search page, not when I'm
just browsing ebay.

Comment 16

16 years ago
this is probably a dupe of bug 153815, which has been fixed for some time.  Has
anybody reproduced this with builds after 1.1 (fix was landed on trunk on Sep 5)?

Comment 17

16 years ago
Based on Andrew's comment above, I downloaded the Windows build for Mozilla 1.2a
last night.  I have tested on both Windows NT 4.0 and Windows 95 OSR2, and so
far I have been unable to reproduce the crash which I could so easily repeat on
the 1.1 release version.  So it looks like Andrew is right.

Comment 18

16 years ago
My one crashes to while browsing ebay.com!

Mozilla 1.1
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1) Gecko/20021015

Comment 19

16 years ago
Yes, of course.  But that is an established fact.

marking dupe of bug 153815

*** This bug has been marked as a duplicate of 153815 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.