gronalund.com - occasional crashes (Gdk-related)

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Per Ångström, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020830
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020830

The web site http://www.gronalund.com/ uses Javascript to move objects about on
the screen. Sometimes the browser will crash when I try to access the page while
the object is moving.

Reproducible: Sometimes

Steps to Reproduce:
The problem is a bit difficult to reproduce, but here are some hints:
1. Open the page and wait for the moving object (probably a balloon).
2. Click the object.
3. Wait for a message box with an error message. (The error message is probably
due to bad Javascript.)
4. Click OK with the mouse.
Actual Results:  
Sometimes the browser will crash. It seems that it happens more often if I
dismiss the message box using the mouse than if I press Escape.

Expected Results:  
At least the browser should not crash.

The following error message is written to the console: 
"Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed."

I don't have a talkback-enabled build.

Updated

16 years ago
Keywords: crash, stackwanted

Comment 1

16 years ago
WFM 2002-09-03-12 Linux -- I did crash using -08-30-05

Can you try a newer build?
(Reporter)

Comment 2

16 years ago
I cannot reproduce the problem in build 20020904, so I'm resolving as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.