Closed Bug 1664190 Opened 3 months ago Closed 3 months ago

Update pdf.js to version 2.7.43

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox81 --- verified
firefox82 --- verified

People

(Reporter: RyanVM, Assigned: RyanVM)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1663803 +++

Changes since last update:
#12354 Ensure that the container div, on BaseViewer-instances, is absolutely positioned
#12352 Remove CSS variables feature-testing from PDFSidebarResizer
#12356 Set the modification date to the current day when saving
#12349 Follow-up comments on PR #12344
#12357 PDF names need to be escaped when saving

Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8db55824c06
Update pdf.js to version 2.7.37. r=bdahl

This is a cherry-pick of the following upstream commit:
https://github.com/mozilla/pdf.js/pull/12357

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Comment on attachment 9174910 [details]
Bug 1664190 - PDF names need to be escaped when saving. r=bdahl

Beta/Release Uplift Approval Request

  • Click on the checkboxes on the top right
  • Save the file and open it in Foxit
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Name escaping is pretty simple and we've tests to check that everything is ok.
  • String changes made/needed:
Attachment #9174910 - Flags: approval-mozilla-beta?
Attachment #9174905 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

The problem isn't totally fixed.
Another PR is in review:
https://github.com/mozilla/pdf.js/pull/12364
So I guess we should do the uplift after cherry picking this patch.

To make tracking easier, I'm just going to reopen this bug to keep all the relevant changes in one place.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 82 Branch → ---

Comment on attachment 9174905 [details]
Bug 1664190 - Update pdf.js to version 2.7.37. r=bdahl

We only need to uplift the cherry-pick patch.

Attachment #9174905 - Flags: approval-mozilla-beta?

Changes since last update:
#12360 Reset cursor position when focus is out of text field
#12362 Let the loadingBar have the same width as the viewerContainer
#12364 Dict keys need to be escaped too when saving

Summary: Update pdf.js to version 2.7.37 → Update pdf.js to version 2.7.43
Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd01981c8f45
Update pdf.js to version 2.7.43. r=bdahl

Comment on attachment 9174910 [details]
Bug 1664190 - PDF names need to be escaped when saving. r=bdahl

This has test failures that the full m-c patch doesn't have :(
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=315472533&repo=try&lineNumber=7984

Comment on attachment 9174910 [details]
Bug 1664190 - PDF names need to be escaped when saving. r=bdahl

(In reply to Ryan VanderMeulen [:RyanVM] from comment #13)

This has test failures that the full m-c patch doesn't have :(
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=315472533&repo=try&lineNumber=7984

Turns out the previous iteration of the uplift patch lost a hunk. Green on Try now with that fixed. Hooray for tests.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c6cd6c9db0c11ff8ee8fac73f4751bce09ef5ed7

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

Comment on attachment 9174910 [details]
Bug 1664190 - PDF names need to be escaped when saving. r=bdahl

Approved for 81.0rc1.

Attachment #9174910 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified using latest nightly this is indeed better fixed on some 3rd party apps (Foxit, Chrome), but not entirely. In Acrobat there still are some issues. I think a followup bug will be required for https://github.com/mozilla/pdf.js/issues/12373. I'll mark this as verified and continue the work for the remaining issue as soon as a patch is available in another bug. If reopening this one is preferred, the status flags need to be changed, marking as verified for now.

(In reply to Bogdan Maris [:bogdan_maris], Release Desktop QA from comment #18)

I'll mark this as verified and continue the work for the remaining issue as soon as a patch is available in another bug.

Yeah, we'll worry about this in a new bug.

Also verified in Firefox 81.0 RC.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.