Closed Bug 1664408 Opened 8 months ago Closed 8 months ago

Mobile bootstrap fails when `~/.mozbuild/mozboot/` is not empty

Categories

(Firefox Build System :: Toolchains, defect, P3)

defect

Tracking

(firefox-esr68 unaffected, firefox-esr78 wontfix, firefox80 wontfix, firefox81 wontfix, firefox82 fixed)

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox80 --- wontfix
firefox81 --- wontfix
firefox82 --- fixed

People

(Reporter: gsvelto, Assigned: rstewart)

References

(Regression)

Details

(Keywords: in-triage, regression)

Attachments

(1 file)

I ran ./mach bootstrap for Android this morning and it failed it failed here because the folder contained old Android NDKs from previous bootstrap runs.

I suppose we can either force the removal of the non-empty folder or handle the error and go on. I don't know what would be the best solution here. I solved the issue locally by manually removing the old NDKs.

Severity: -- → S3
Keywords: in-triage
Priority: -- → P3
Assignee: nobody → rstewart

The idea here was that we keep the NDK's downloaded in this directory as a "cache", such that if the download gets interrupted, then we can resume the download from an earlier point. This logic was walked back by bug 1637379, which deletes the cache.

In the spirit of the original version of the code, remove the os.rmdir() that was introduced by that bug.

An alternative fix for this is to download the NDK to a temporary directory and just clean that up entirely after every call to mach bootstrap, but then we would be forgoing the build cache behavior, which I'm not sure makes sense at this point in time.

Attachment #9175552 - Attachment description: Bug 1664408 - Download Android NDK to a temporary directory instead of into `mozboot` → Bug 1664408 - Don't delete `~/.mozbuild/mozboot` directory after use in `bootstrap`
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7989a40e6c89
Don't delete `~/.mozbuild/mozboot` directory after use in `bootstrap` r=mhentges,nalexander
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.