certificates cannot be deleted

VERIFIED DUPLICATE of bug 154040

Status

VERIFIED DUPLICATE of bug 154040
16 years ago
2 years ago

People

(Reporter: marcus, Assigned: ssaux)

Tracking

1.0 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020826

ok.. I don't know what component to file this under. It seems to me, that it
should be PSM 8after careful study of a hundred pages) but that is not in the
droplist anymore.
So: I have an outdated certificate, and want to delete it, so that I can
establish a https session again, but nothing happens. I use r1.1 German. I have
to start up r1.0 (which happens to be english) and there I can delete the very
same certificate without problem. Note: there is no error message, it just
doesn't go away.

Reproducible: Always

Steps to Reproduce:
1.Go to Bearbeiten
2.Einstellungen
3.Privatspäre & Sicherheit
4.Zertifikate
5. Zertifikate verwalten
6.Websites
7.chosse any certificate accepted prevously
8.Löschen
9. Ok
10. nothing happens

Actual Results:  
nothing

Expected Results:  
the certificate should have been removed
Thank you for attempting to find the correct component - you tried a lot harder
than most. PSM is considered a separate "product" in Bugzilla, and you'll find
it in the Product drop-down list. I'm reassigning this bug there now.
Assignee: mstoltz → ssaux
Component: Security: General → Client Library
Product: Browser → PSM
QA Contact: bsharma → junruh
Version: other → 2.4

Comment 2

16 years ago
What tab is showing in the Certificate Manager when you are trying to delete a 
cert? Do you have FIPS enabled?
If this is a personal cert, a workaround is Edit>Prefs>Privacy>Master 
Passwords>Reset master password.
(Reporter)

Comment 3

16 years ago
I was trying to delete a website certificate
I never usede FIPS, so it is set at the default value, whatever that is.
I never user a master password, so I don't understand how this could solve my 
problem. My workaround was to use Mozilla 1.0, where it works without problem, 
on the same profile. Fortunately one can use 1.1 and 1.0 alternatingly.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 154040 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified fixed in the latest nightly build -www.mozilla.org
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.4 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.