Closed Bug 1664634 Opened 2 years ago Closed 2 years ago

Unremovable and even unmovable 'DevTools' toolbar item

Categories

(Thunderbird :: Add-Ons: General, defect)

x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: nicholas_j, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image Untitled.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

Installed Thunderbird 78.2.2, via downloaded .exe. Ran it.

Actual results:

There is an unremovable and even unmovable item called 'DevTools' - see screenshot. If I try to move it, the attempt fails. If It try to remove it, the attempt fails.

Expected results:

  1. The item should not be there at all. For, it was not there before.
  2. When the item is there, it should be removable.
  3. When the item is there, it should be movable.
Component: Untriaged → General

The Dev Tools, Options and Config buttons on the right of that screenshot appear to be added by an extension.
Possibly Phoenity Buttons
>- It may be necessary to restart Thunderbird for buttons to move or appear.

Currently only a few (unmovable) buttons are available:

  • Search Messages, Config Editor, Developer Tools, Preferences & Restart.

Not sure why it wasn't there before.

I have added the Add-ons button to the Mail toolbar from Customize, but don't see the others there.

Blocks: tb78found

Reporter, do you have the Phoenity Buttons extension installed?

Component: General → Add-Ons: General
Flags: needinfo?(nicholas_j)
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Yes, I do have that extension installed, and active.

Flags: needinfo?(nicholas_j)

Then you noticed in comment #1 that the extensions developer indicates those icons are unmovable?

Do they disappear when you restart in safe mode using Help > Restart with Add-ons disabled?

Flags: needinfo?(nicholas_j)

No, I did not notice. That is because I am giving this bug report minimal attention. The reason for that in turn is that I have decided for the time being to remain on Thunderbird 68. For the same reason I will not be testing Thunderbird 78 in safe mode, though I admit that I should have done that before I filed the bug. (My reasons for not engaging further include: having an all-round a bad experience with 78; having a hard time reverting to 68.)

Flags: needinfo?(nicholas_j)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.